[osg-users] [osgPPU] build osgPPU

Guy guy at dvp.co.il
Thu Mar 26 05:57:33 PDT 2009


Forget it, sorry, I found the files :)
The OSG_GEN_INCLUDE is where the CMake generated the solution and the
files are there.

Sorry for the noise,
 Guy.

----------


I forgot to mention, when I try to compile the project it complains it
doesn't find osg/Config and OpenThreads/Config. These files are not
under the osg include so I thought the mistake is from there and the
osgPPU tries to generate them. I was told that these files sets how the
BoundingSphere and Box are used among other things. So this might
explain linkage problem of not finding these implementation with double
(my configuration was for float)... hmmm.. where are these files hiding?
Maybe I don't need these files, just add precompile definitions?

Thanks,
 Guy. 

----------


OK Art,
 Maybe I'm making mistakes with the CMake configuration.
I run CMake 2.6.3 on the trunk version of PPU. I get errors about
finding the OSG libraries, but this is no problem to set them correctly.
One of the suspicious warnings CMake generate is:

/Quote

CMake Warning (dev) at CMakeLists.txt:45 (INCLUDE):
  Policy CMP0011 is not set: Included scripts do automatic cmake_policy
PUSH
  and POP.  Run "cmake --help-policy CMP0011" for policy details.  Use
the
  cmake_policy command to set the policy and suppress this warning.

  The included script

    E:/OSG/osgPPU/osgPPU/CMakeModules/cuda/FindCuda.cmake

  affects policy settings.  CMake is implying the NO_POLICY_SCOPE option
for
  compatibility, so the effects are applied to the including context.
This warning is for project developers.  Use -Wno-dev to suppress it.

/Quote

Which seems harmless.

It doesn't find CUT and CUT_INCLUDE which I've no idea what are these
things...

Under the OSG group, what is OSG_DIR? Where all the osg binaries are?
I didn't 'install' osg. Just compiled it.

And does OSG_GEN_INCLUDE_DIR and OSG_INCLUDE_DIR are the same?

After I fix the libraries paths and reconfigure I'm asked about osg
major minor patch and SO versions. Which as far as I get are 2,8,0 and I
have no clue what is SO_VERSION so I put 2 also there.

Do I do anything wrong?

----------


Hi Guy,

hmm, maybe you confound the Config.h of osgPPU with the Config.h of OSG.
These are different things. Currently in osgPPU/Export.h the Config.h is
not used at all, hence it shouldn't be any problem when building the
osgPPU. Including hte osg/Config.h is also not required, because all the
needed information about the current OSG-Setup can be acquired from
osgversion (this is also how it is done currently).

Cheers,
art

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=9281#9281





_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g



More information about the osg-users mailing list