[osg-users] Osgconv --formats broke on Mac OSX

Paul Martz pmartz at skew-matrix.com
Tue Mar 24 12:12:10 PDT 2009


Well, this is nothing that an update won't fix. :-) Using current svn head
resolves the issue. The plugins are still named .so, but the osgDB actually
looks for ".so" now. Still not sure if this was broke in 2.8 or not, but
it's fixed in 2.9.2.
 
Thanks, Eric. And, sorry we didn't get to hook up in DC earlier this month.
 
Paul Martz
Skew Matrix Software LLC
http://www.skew-matrix.com <http://www.skew-matrix.com/> 
+1 303 859 9466
 

  _____  

From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Eric
Sokolowsky
Sent: Tuesday, March 24, 2009 1:05 PM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Osgconv --formats broke on Mac OSX


My plugins all have the .so extension. The main libraries all have .dylib.
Someday we'll get Frameworks working properly but that day is not today.

The only thing I know of that changed very recently was that under OSX, the
debug library suffix (by default "d") was not being added properly when
using the Debug configuration, because _DEBUG was not being passed
correctly. This is still potentially a problem for Makefile builds. Are you
doing a Debug build or a Release build? Plugins were broken for Debug
builds. One of my submissions has not yet been integrated; see
osg-submissions for details.

You might also try using the Xcode generator; you can use the command-line
compiler to actually compile things if you don't like the IDE (I use an
install directory in my home directory for testing):

xcodebuild -configuration Release -target install

-Eric


2009/3/24 Paul Martz <pmartz at skew-matrix.com>


I am generating Makefiles using CMake, and I have installed OSG.
 
The problem seems to be that osgDB expects plugins to have a ".dylib"
extension, when in fact they have a ".so" extension on my system (and no
they are not sym links). Eric, I'd be interested to know what you have on
your system.
 
Did the extension for OS X plugins change very recently? My build is a
couple weeks old now.
 
Paul Martz
Skew Matrix Software LLC
http://www.skew-matrix.com <http://www.skew-matrix.com/> 
+1 303 859 9466
 

  _____  

From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Eric
Sokolowsky
Sent: Tuesday, March 24, 2009 11:42 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Osgconv --formats broke on Mac OSX


It works for me (latest svn). Did you "install" the OSG library? If you did
not, there is no way to get to the plugins, because Xcode inserts a "Debug"
or "Release" intermediate directory. This assumes you use the Xcode
generator for OSX. If you are using the Makefiles generator, or the old
pre-generated Xcode project, then I have no idea.

-Eric


2009/3/24 Paul Martz <pmartz at skew-matrix.com>


Is anyone else encountering this? "osgconv --formats" immediately returns to
the shell prompt. With OSG_NOTIFY_LEVEL set to DEBUG_INFO I see that it
finds the plugin directory, then pretty much just exits, as if there are no
plugins there.
 
Oddly, "osgconv --format flt" (and other extensions) works OK, and with the
notify output I see it finding the plugin immediately, followed by the
expected output relating to that plugin.
 
OSG 2.6.1 works OK. but svn head is broke as of at least late February
(that's when I took the snapshot for our OSG training in DC, and one of the
students there with a macbook encountered the issue). I haven't tried this
with 2.8.
 
Paul Martz
Skew Matrix Software LLC
http://www.skew-matrix.com <http://www.skew-matrix.com/> 
+1 303 859 9466
 

_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org





_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090324/d623d60b/attachment-0003.htm>


More information about the osg-users mailing list