[osg-users] Build Error on Windows

Robert Osfield robert.osfield at gmail.com
Tue Mar 24 11:03:33 PDT 2009


Hi Mark,

On Tue, Mar 24, 2009 at 5:42 PM, Mark Sciabica <msciabica at itracs.com> wrote:

> The versioning of the dll's doesn't completely solve the problem. I have
> customized OSG for my application, changing the public interface in a way
> such that the objects are not binary compatible with vanilla OSG. Linking
> dll's without my customizations can cause crashes. I install my customized
> build into a private directory in an attempt to avoid this problem. However,
> this "feature" thwarts my efforts.


I do hope you are publishing these changes to the core OSG, this is a
requirement of the OSGPL/LGPL.


> And this problem affects more than just those who customize OSG. On
> Windows, we also need to contend with compatibility between builds from
> different compiler versions, and compiler options (e.g. linking debug vs.
> release or static vs dynamic runtime libraries). If two applications are
> installed, both using OSG 2.8.0, they need to be built with the same
> compiler version and same options or problems will ensue as they use the
> same path to load plugins.


If you have incompatible versions then you should bump the SO version number
to avoid contention.

Robert.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090324/f514f05d/attachment-0003.htm>


More information about the osg-users mailing list