[osg-users] OSG 2.6.1 and VPB

Robert Osfield robert.osfield at gmail.com
Sun Mar 22 03:59:20 PDT 2009


Hi Michael,

Normally this is pretty straight forward, you just need to point you library
path at the libraries, either via LD_LIBRARY_PATH or your /etc/ld.so.conf.
Obviously you are doing something wrong along the route, but there is no way
for me to know what this is though as I don't have you machine in front of
me.  If you have some colleagues then please get them to walk you through
setting up of paths.

Robert.

On Mon, Mar 16, 2009 at 11:52 PM, Michael W. Hall <hallmw at att.net> wrote:

> Robert,
>
> I have LD_LIBRARY defined as /usr/local/lib64.  This is where
> libOpenThreads.so.11 is located.  I uninstalled OSG and did a make
> clean.  I then ran make and make install.  I am still getting the same
> error.  I am running FC10 x86_64.  should I make a symbolic link
> in /usr/local/lib?  Let me know if I am missing something else.  I am
> going to give that a try.
>
> Michael
>
> On Sat, 2009-03-07 at 09:49 +0000, Robert Osfield wrote:
> > Hi Michael,
> >
> > You either have to install OSG and VPB or set up LD_LIBARARY and PATH
> > env vars to point to respective lib and bin directories.
> >
> > Robert.
> >
> > On Sat, Mar 7, 2009 at 1:01 AM, Michael W. Hall <hallmw at att.net> wrote:
> > > I appreciate the reply.  I got OSG 2.6.1 and followed the info you
> > > provided to get the version of VPB that was was listed in the table to
> > > work with the version of OSG I have installed.
> > >
> > > It has been a while since I have played with it, but the both build and
> > > installed.  When I try to run osgversion, I get the following:
> > >
> > > ./osgversion: error while loading shared libraries:
> > > libOpenThreads.so.11: cannot open shared object file: No such file or
> > > directory
> > >
> > > I have checked and the above lib is there.  When I run osgdem, I get
> the
> > > following error:
> > >
> > > osgdem: error while loading shared libraries: libvpb.so.8: cannot open
> > > shared object file: No such file or directory
> > >
> > > That lib is there also.  Any ideas to try? I am running FC10.
> > >
> > > Thanks,
> > > Michael
> > >
> > >
> > > On Sun, 2009-01-25 at 11:58 +0100, Ralf Stokholm wrote:
> > >> Hi Michael
> > >>
> > >> I have set up my build of osg using externals in svn.
> > >>
> > >>
> > >> osg
> > >>
> http://www.openscenegraph.org/svn/osg/OpenSceneGraph/tags/OpenSceneGraph-2.6.1
> > >> osgdata -r7561
> > >> http://www.openscenegraph.org/svn/osg/OpenSceneGraph-Data/trunk
> > >> 3rdPartysvn -r403
> > >>
> https://osgtoy.svn.sourceforge.net/svnroot/osgtoy/3rdParty/branches/3rdParty_win32binaries_vs80sp1
> > >> osgdem -r927
> > >> http://www.openscenegraph.org/svn/VirtualPlanetBuilder/trunk
> > >>
> > >> this should work, at least it does on Windows xp and visual studio.
> > >>
> > >> If you simply want to get VPB in 924 or 927 which works for me, then
> > >> simply do an update to revision in svn.
> > >>
> > >> Hope this helps.
> > >>
> > >> Brgs.
> > >> Ralf Stokholm
> > >> www.arenalogic.com
> > >>
> > >>
> > >> 2009/1/25 Michael W. Hall <hallmw at att.net>
> > >>         I have built OSG 2.6.1.  Now I am trying to get the VPB to
> > >>         build.  I got
> > >>         the latest from SVN, but I see that the chart says VPB r924 is
> > >>         the one
> > >>         to use.  Could someone tell me how to get the version of VPB
> > >>         that will
> > >>         compile against OSG 2.6.1?
> > >>
> > >>         I am using Fedora Core 10 x86_64.
> > >>
> > >>         Thanks,
> > >>         Michael
> > >>
> > >>         _______________________________________________
> > >>         osg-users mailing list
> > >>         osg-users at lists.openscenegraph.org
> > >>
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >>
> > >> _______________________________________________
> > >> osg-users mailing list
> > >> osg-users at lists.openscenegraph.org
> > >>
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > > _______________________________________________
> > > osg-users mailing list
> > > osg-users at lists.openscenegraph.org
> > >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090322/d66aca5b/attachment-0003.htm>


More information about the osg-users mailing list