[osg-users] FFmpeg plugin

Robert Osfield robert.osfield at gmail.com
Fri Mar 20 10:22:50 PDT 2009


HI Carlos,

As I don't see any of these problems, I'm afraid there isn't much I can do
apart from make suggestions for you to try out.  Right now it looks like
you'll need to add the zlib library into the build of other ffmpeg or our
plugin.

Robert.

2009/3/20 Carlos Sanches <cesmsp at gmail.com>

> :(
> ok.
> I downloaded,  compiled and instaled zlib-1.2.3
> built ffmpeg from svn again with new zlib installed
> in osg i changed the directories of zlib to the new zlib in ccmake
> cmakelist.txt
> in OpenSceneGraph-2.9.1 directory:
> ./configure
> make clean
> make
>
> the example was built again but .
> running example with ./osgmovie -e ffmpeg video.avi   or .mpg
> the movie runs but the same error apears.
>
> Warning: dynamic library '/usr/local/lib/osgPlugins-2.9.1/osgdb_ffmpeg.so'
> exists, but an error occurred while trying to open it:
> /usr/local/lib/osgPlugins-2.9.1/osgdb_ffmpeg.so: undefined symbol:
> inflateInit_
> image->s()640 image-t()=480 aspectRatio=1
> Transparent movie, enabling blending.
>
> My sistem is Ubuntu 8.04
> videocard  nvidia 8800 gtx
> motherboard P5N-T DELUXE
> Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
>
> say me if you need more information .
> i realy need to play movies with ffmpeg.
>
> tks
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 2009/3/20 Robert Osfield <robert.osfield at gmail.com>
>
>> Hi Carlos,
>>
>> What happens when you run:
>>
>>    osgmovie -e ffmpeg a_video.mpg
>>
>> Is it still reporting that it can't load the plugin?
>>
>> I suspect that you are still hitting against the plugin not loading
>> correctly.  The inflatInit method is still being reported as not found and
>> this function is from zlib then ffmpeg is built without linking against zlib
>> which is needs.  Linking against zlib ourselves in our ffmpeg could a
>> solution.
>>
>> It's odd that you're having problems wheras others aren't.  What is the
>> exact spec of your system?
>>
>> Robert.
>>
>> 2009/3/20 Carlos Sanches <cesmsp at gmail.com>
>>
>> ok , now i m using svn version of ffmpeg.
>>> bow the example runs but the message still apear
>>>
>>> I put the the lines in main function of my program::
>>>
>>> std::string libName =  osgDB::Registry::instance()->createLibraryNameForExtension("ffmpeg");
>>> osgDB::Registry::instance()->loadLibrary(libName);
>>>
>>> but looks like that its using xine yet .
>>> and the old error continues.
>>>
>>>
>>> *** glibc detected *** ./OSG: free(): invalid pointer: 0x0b1f8fc7 ***
>>> ======= Backtrace: =========
>>> /lib/tls/i686/cmov/libc.so.6[0xb73e9a85]
>>> /lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb73ed4f0]
>>> /usr/local/lib/osgPlugins-2.9.1/osgdb_xine.so[0xb7f7c823]
>>> /usr/lib/libxine.so.1[0xb58484d8]
>>> ======= Memory map: ========
>>>
>>> Why my ffmpeg is not in use ?
>>> I have to modify something in osgDB ?
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> 2009/3/20 Robert Osfield <robert.osfield at gmail.com>
>>>
>>> HI Carlos,
>>>>
>>>> Our plugin doesn't contain any inflateInit_ or inflate method of any
>>>> kind, so the missing sybmol must be coming from ffmpeg itself.  I haven't
>>>> see this error myself when building from various versions of ffmpeg so
>>>> perhaps it's version 0.5 that has gone astray.
>>>>
>>>> Have a look in ffmpeg itself for the inflateInit_ method.  Another thing
>>>> you could try is using the svn version of ffmpeg, or the ffmpeg libs pulled
>>>> down from the Ubuntu repositories.
>>>>
>>>> Robert.
>>>>
>>>>
>>>> 2009/3/19 Carlos Sanches <cesmsp at gmail.com>
>>>>
>>>>> Ok , I did it .
>>>>> now I m trying to run de example:
>>>>>  osgmovie -e ffmpeg
>>>>>
>>>>> this error occours
>>>>>
>>>>> Warning: dynamic library
>>>>> '/usr/local/lib/osgPlugins-2.9.1/osgdb_ffmpeg.so' exists, but an error
>>>>> occurred while trying to open it:
>>>>> /usr/local/lib/osgPlugins-2.9.1/osgdb_ffmpeg.so: undefined symbol:
>>>>> inflateInit_
>>>>> Usage: ./osgmovie [options] filename ...
>>>>> Options:
>>>>> ...
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> 2009/3/19 Adrian Egli OpenSceneGraph (3D) <3dhelp at gmail.com>
>>>>>
>>>>>> I am working with windows, no problem there, but here my settings.
>>>>>> Variable Name: FFMPEG_LIBAVCODEC_INCLUDE_DIRS
>>>>>> Description: Path to a file.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include/LIBAVCODEC
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVCODEC_LIBRARIES
>>>>>> Description: Path to a library.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/lib/avcodec-52.lib
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVDEVICE_INCLUDE_DIRS
>>>>>> Description: Path to a file.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include/LIBAVDEVICE
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVDEVICE_LIBRARIES
>>>>>> Description: Path to a library.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/lib/avdevice-52.lib
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVFORMAT_INCLUDE_DIRS
>>>>>> Description: Path to a file.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include/LIBAVFORMAT
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVFORMAT_LIBRARIES
>>>>>> Description: Path to a library.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/lib/avformat-52.lib
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVUTIL_INCLUDE_DIRS
>>>>>> Description: Path to a file.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include/LIBAVUTIL
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBAVUTIL_LIBRARIES
>>>>>> Description: Path to a library.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/lib/avutil-49.lib
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBSWSCALE_INCLUDE_DIRS
>>>>>> Description: Path to a file.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include/libswscale
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_LIBSWSCALE_LIBRARIES
>>>>>> Description: Path to a library.
>>>>>> Current Value: F:/dev/ffmpeg/SDK/lib/swscale-0.lib
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>> Variable Name: FFMPEG_ROOT
>>>>>> Description: Location of FFMPEG
>>>>>> Current Value: F:/dev/ffmpeg/SDK/include
>>>>>> New Value (Enter to keep current value):
>>>>>>
>>>>>>
>>>>>> 2009/3/19 Carlos Sanches <cesmsp at gmail.com>
>>>>>>
>>>>>> Hi Adrian !
>>>>>>> ok, I have the ffmpeg installed . I use it to convert my movies.
>>>>>>> Now I m seeing in ccmake configure list . but have some options that
>>>>>>> I dont know what I have to put there.
>>>>>>> the options are :
>>>>>>>
>>>>>>> FFMPEG_LIBAVCODEC_INCLUDE_DIRS
>>>>>>> /usr/include
>>>>>>>
>>>>>>>  FFMPEG_LIBAVCODEC_LIBRARIES
>>>>>>> /usr/lib/libavcodec.so
>>>>>>>
>>>>>>>  FFMPEG_LIBAVDEVICE_INCLUDE_DIR
>>>>>>> FFMPEG_LIBAVDEVICE_INCLUDE_DIRS-NOTFOUND
>>>>>>>
>>>>>>>  FFMPEG_LIBAVDEVICE_LIBRARIES
>>>>>>> FFMPEG_LIBAVDEVICE_LIBRARIES-NOTFOUND
>>>>>>>
>>>>>>>  FFMPEG_LIBAVFORMAT_INCLUDE_DIR
>>>>>>> /usr/include
>>>>>>>
>>>>>>>  FFMPEG_LIBAVFORMAT_LIBRARIES
>>>>>>> /usr/lib/libavformat.so
>>>>>>>
>>>>>>>  FFMPEG_LIBAVUTIL_INCLUDE_DIRS
>>>>>>> /usr/include
>>>>>>>
>>>>>>>  FFMPEG_LIBAVUTIL_LIBRARIES
>>>>>>> /usr/lib/libavutil.so
>>>>>>>
>>>>>>>  FFMPEG_LIBSWSCALE_INCLUDE_DIRS
>>>>>>> /usr/include
>>>>>>>
>>>>>>>  FFMPEG_LIBSWSCALE_LIBRARIES
>>>>>>> /usr/lib/libswscale.so
>>>>>>>
>>>>>>>  FFMPEG_ROOT
>>>>>>>
>>>>>>>
>>>>>>> The options that I believe that must be wrong are:
>>>>>>> FFMPEG_LIBAVDEVICE_INCLUDE_DIR
>>>>>>>  FFMPEG_LIBAVDEVICE_LIBRARIES
>>>>>>>  FFMPEG_ROOT
>>>>>>>
>>>>>>> What I have to do in these options ?
>>>>>>> tks
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> 2009/3/19 Adrian Egli OpenSceneGraph (3D) <3dhelp at gmail.com>
>>>>>>>
>>>>>>> Hi Carlos
>>>>>>>> You have to donwload ffmpeg and build the plugin by setting up the
>>>>>>>> right parameters in cmake. then osg will build the ffmpeg plugin as well as
>>>>>>>> the other 3rd party plugins will be build.
>>>>>>>>
>>>>>>>> adrian
>>>>>>>>
>>>>>>>> 2009/3/18 Carlos Sanches <cesmsp at gmail.com>
>>>>>>>>
>>>>>>>> Hi Robert.
>>>>>>>>> I m seeing that my /usr/local/lib/osgPlugins-2.9.1  directory dont
>>>>>>>>> have the plugin for ffmpeg .
>>>>>>>>> this is correct ?
>>>>>>>>> I put this in my code ...
>>>>>>>>>     std::string libName =
>>>>>>>>> osgDB::Registry::instance()->createLibraryNameForExtension("ffmpeg");
>>>>>>>>>     osgDB::Registry::instance()->loadLibrary(libName);
>>>>>>>>>
>>>>>>>>> but how I know if it is using ffmpeg ?
>>>>>>>>>
>>>>>>>>> tks
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> 2009/3/16 Robert Osfield <robert.osfield at gmail.com>
>>>>>>>>>
>>>>>>>>> Hi Carlos,
>>>>>>>>>>
>>>>>>>>>> Have a look at the osgmovie example for guidance, it'll boil down
>>>>>>>>>> to reading a image, and assing to the a textured quad.  Right now you'll
>>>>>>>>>> need to preload the ffmpeg plugin as osgDB won't yet automatically alias the
>>>>>>>>>> movie extensions to ffmpeg.  On the movie command line you use the option -e
>>>>>>>>>> ffmpeg to pre load the plugin.  Programatically you'd use:
>>>>>>>>>>
>>>>>>>>>> std::string libName =
>>>>>>>>>> osgDB::Registry::instance()->createLibraryNameForExtension("ffmpeg");
>>>>>>>>>> osgDB::Registry::instance()->loadLibrary(libName);
>>>>>>>>>>
>>>>>>>>>> Robert.
>>>>>>>>>>
>>>>>>>>>> 2009/3/16 Carlos Sanches <cesmsp at gmail.com>
>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Hi all !
>>>>>>>>>>> I downloaded osg 2.9.1 . I m using  pImageStream =
>>>>>>>>>>> dynamic_cast<osg::ImageStream*>(hudImage);
>>>>>>>>>>> to open a movie.
>>>>>>>>>>> What have I to do to use ffmpeg to read my movies ?
>>>>>>>>>>>
>>>>>>>>>>> tks
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> osg-users mailing list
>>>>>>>>>>> osg-users at lists.openscenegraph.org
>>>>>>>>>>>
>>>>>>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> _______________________________________________
>>>>>>>>>> osg-users mailing list
>>>>>>>>>> osg-users at lists.openscenegraph.org
>>>>>>>>>>
>>>>>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> _______________________________________________
>>>>>>>>> osg-users mailing list
>>>>>>>>> osg-users at lists.openscenegraph.org
>>>>>>>>>
>>>>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> ********************************************
>>>>>>>> Adrian Egli
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> osg-users mailing list
>>>>>>>> osg-users at lists.openscenegraph.org
>>>>>>>>
>>>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>>    Carlos Sanches
>>>>>>> Programação Gráfica;
>>>>>>>
>>>>>>> Tel:  55 11 3816 2888
>>>>>>> Cel: 55 11 9650 7137
>>>>>>>
>>>>>>>       Somar Meteorologia
>>>>>>> www.somarmeteorologia.com.br
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> osg-users mailing list
>>>>>>> osg-users at lists.openscenegraph.org
>>>>>>>
>>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> ********************************************
>>>>>> Adrian Egli
>>>>>>
>>>>>> _______________________________________________
>>>>>> osg-users mailing list
>>>>>> osg-users at lists.openscenegraph.org
>>>>>>
>>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> --
>>>>>    Carlos Sanches
>>>>> Programação Gráfica;
>>>>>
>>>>> Tel:  55 11 3816 2888
>>>>> Cel: 55 11 9650 7137
>>>>>
>>>>>       Somar Meteorologia
>>>>> www.somarmeteorologia.com.br
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> osg-users mailing list
>>>>> osg-users at lists.openscenegraph.org
>>>>>
>>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>>
>>>>>
>>>>
>>>> _______________________________________________
>>>> osg-users mailing list
>>>> osg-users at lists.openscenegraph.org
>>>>
>>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>>
>>>>
>>>
>>>
>>> --
>>>    Carlos Sanches
>>> Programação Gráfica;
>>>
>>> Tel:  55 11 3816 2888
>>> Cel: 55 11 9650 7137
>>>
>>>       Somar Meteorologia
>>> www.somarmeteorologia.com.br
>>>
>>>
>>> _______________________________________________
>>> osg-users mailing list
>>> osg-users at lists.openscenegraph.org
>>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>>
>>>
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>
>
> --
>    Carlos Sanches
> Programação Gráfica;
>
> Tel:  55 11 3816 2888
> Cel: 55 11 9650 7137
>
>       Somar Meteorologia
> www.somarmeteorologia.com.br
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090320/819aa91a/attachment-0003.htm>


More information about the osg-users mailing list