[osg-users] FFmpeg plugin

Carlos Sanches cesmsp at gmail.com
Wed Mar 18 11:15:46 PDT 2009


Hi Robert.
I m seeing that my /usr/local/lib/osgPlugins-2.9.1  directory dont have the
plugin for ffmpeg .
this is correct ?
I put this in my code ...
    std::string libName =
osgDB::Registry::instance()->createLibraryNameForExtension("ffmpeg");
    osgDB::Registry::instance()->loadLibrary(libName);

but how I know if it is using ffmpeg ?

tks




2009/3/16 Robert Osfield <robert.osfield at gmail.com>

> Hi Carlos,
>
> Have a look at the osgmovie example for guidance, it'll boil down to
> reading a image, and assing to the a textured quad.  Right now you'll need
> to preload the ffmpeg plugin as osgDB won't yet automatically alias the
> movie extensions to ffmpeg.  On the movie command line you use the option -e
> ffmpeg to pre load the plugin.  Programatically you'd use:
>
> std::string libName =
> osgDB::Registry::instance()->createLibraryNameForExtension("ffmpeg");
> osgDB::Registry::instance()->loadLibrary(libName);
>
> Robert.
>
> 2009/3/16 Carlos Sanches <cesmsp at gmail.com>
>
>>
>> Hi all !
>> I downloaded osg 2.9.1 . I m using  pImageStream =
>> dynamic_cast<osg::ImageStream*>(hudImage);
>> to open a movie.
>> What have I to do to use ffmpeg to read my movies ?
>>
>> tks
>>
>>
>>
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20090318/c1ff5985/attachment-0003.htm>


More information about the osg-users mailing list