[osg-users] OSG trunk crash when use osgdb_osgparticle plugin

Robert Osfield robert.osfield at gmail.com
Fri Mar 13 08:11:23 PDT 2009


Hi David,

Just tried various .osg files with particles systems and they all work
fine with svn/trunk + 2.9.1.  My guess is that you have an out of sync
set of libs/plugins, try a clean build and make sure that you don't
have older but the same so version number libs hanging around.

Robert.

On Fri, Mar 13, 2009 at 2:22 PM, David Callu <ledocc at gmail.com> wrote:
> Hi all
>
> osgviewer crash when i try to load any data which require osgdb_osgparticle,
> in release and debug mode
> - osgviewer cessnafire.osg
> - osgviewer spaceship.osg
> - osgviewer fountain.osg
> - osgviewer osgcool.osg
> - osgviewer SmoxeBox.osg
> - osgblendequation (it use cessnafire.osg)
>
> Crash occure when osgdb_osgparticle is loaded and used.
> If i do
> # osgviewer my_osg_path/osgdb_osgparticle.so cow.osg
> all work fine.
>
> I use the last OSG SVN version
> Linux Fedora 10
> GCC 4.3.2
> glibc 2.9
>
> backtrace :
>
> *** glibc detected *** osgviewer: corrupted double-linked list: 0x09d89930
> ***
> ======= Backtrace: =========
> /lib/libc.so.6[0xa84e1f]
> /lib/libc.so.6[0xa8692d]
> /lib/libc.so.6(__libc_calloc+0xef)[0xa8848f]
> /lib/libc.so.6[0xa43ae1]
> /lib/libc.so.6(__cxa_atexit+0x20)[0xa43bc0]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/osgPlugins-2.9.1/osgdb_osgparticle.so[0x7c03db]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/osgPlugins-2.9.1/osgdb_osgparticle.so[0x7c8dfd]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/osgPlugins-2.9.1/osgdb_osgparticle.so(_init+0x2c)[0x7af940]
> /lib/ld-linux.so.2[0x4521ed]
> /lib/ld-linux.so.2[0x4568d2]
> /lib/ld-linux.so.2[0x451db6]
> /lib/ld-linux.so.2[0x455f5e]
> /lib/libdl.so.2[0x43897c]
> /lib/ld-linux.so.2[0x451db6]
> /lib/libdl.so.2[0x43805c]
> /lib/libdl.so.2(dlopen+0x4f)[0x4389ff]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/libosgDB.so.56(_ZN5osgDB14DynamicLibrary16getLibraryHandleERKSs+0xef)[0x8ce1af]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/libosgDB.so.56(_ZN5osgDB14DynamicLibrary11loadLibraryERKSs+0x52)[0x8ceed2]
> /home/ledocc/graphisme/osg/SVN/OpenSceneGraph/release/lib/libosgDB.so.56(_ZN5osgDB8Registry11loadLibraryERKSs+0x8f)[0x8f6b3f]
> ...
> ...
> ...
>
>
>
> This bug seem to be really tricky so if anyone could test this commande line
> # osgviewer cessnafire.osg
> and report the result and the OSG version / platform, this could be a nice
> help for track this bug.
>
> Or if anyone have a solution, i am be happy to know it ;-)
>
>
> David
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list