[osg-users] division by zero in osgParticle/FluidProgram.cpp

Robert Osfield robert.osfield at gmail.com
Thu Mar 12 10:03:14 PDT 2009


HI Csaba,

I don't have any strong opinions on these issues, as I'm not very
familiar with the code, and haven't seen problems first hand with the
code segments your pointing out so don't have any extra insight to
provide.  I don't know if you are directly seeing bugs, or just come
across potential problems in a code review.

As you're the first person to point to these potential problems I can
only presume that you have a particular usage model that highlights
them, this does place you in the best place to come up with a fix and
qualify that they are fixed.  As Gordon mentioned, if you do come up
with a fix post them to osg-submissions and then I can review them.

Robert.

On Thu, Mar 12, 2009 at 4:24 PM, Csaba Halász <csaba.halasz at gmail.com> wrote:
> On Thu, Mar 12, 2009 at 5:04 PM, Tomlinson, Gordon
> <GTOMLINSON at overwatch.textron.com> wrote:
>> Read this page http://www.openscenegraph.org/projects/osg/wiki/MailingLists/SubmissionsProtocol
>
> Looks the same as last time :D
> I haven't made a submission, because I was hoping for some discussion
> and a more sophisticated fix than just sticking an if
> (wind_accel.length2() > 0) in there.
>
> --
> Csaba/Jester
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list