[osg-users] [build] make : Build error on FFmpegClocks.hpp while compiling OSG-dev

Robert Osfield robert.osfield at gmail.com
Wed Mar 4 08:28:29 PST 2009


Hi David,

It looks like you pkg-config set up is failing for some reason.  Not
to worry though... as I've just merged a revision to FindFFmpeg.cmake
that replaces the pkg-config usage with standard searching.

Could you do an svn update and rest, hopefully this issue will finally
be put to bed.  Thanks for your patience.

Robert.

On Wed, Mar 4, 2009 at 2:47 PM, david bruyer <osgforum at tevs.eu> wrote:
> Hi robert,
>
> I did everything; here are the results :
> I use the 2.6.1 version of CMAKE
>
>
> Code:
> [david at Mandrake ~]$ rpm -qa | grep cmake
> cmake-2.6.1-1mdv2009.0
> [david at Mandrake ~]$
>
>
>
> Then the pkg-config commands return nothing. But may be i don't use it as it should be...
>
> Code:
>
> [david at Mandrake ~]$ pkg-config --cflags-only-I libavcodec
>
> [david at Mandrake ~]$
>
>
>
> But i'm sure i have this package :
>
>
> Code:
> [david at Mandrake ~]$ locate libavcodec
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin.la
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin_la-audio.lo
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin_la-avcodec.lo
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin_la-deinterlace.lo
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin_la-encoder.lo
> /opt/vlc/0.9.8a/modules/codec/avcodec/libavcodec_plugin_la-video.lo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.deps/libavcodec_plugin_la-audio.Plo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.deps/libavcodec_plugin_la-avcodec.Plo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.deps/libavcodec_plugin_la-deinterlace.Plo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.deps/libavcodec_plugin_la-encoder.Plo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.deps/libavcodec_plugin_la-video.Plo
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin.la
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin.lai
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin.so
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin.soT
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin_la-audio.o
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin_la-avcodec.o
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin_la-deinterlace.o
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin_la-encoder.o
> /opt/vlc/0.9.8a/modules/codec/avcodec/.libs/libavcodec_plugin_la-video.o
> /opt/vlc/0.9.8a/vlc/lib/vlc/codec/libavcodec_plugin.la
> /opt/vlc/0.9.8a/vlc/lib/vlc/codec/libavcodec_plugin.so
> /usr/include/libavcodec
> /usr/include/libavcodec/avcodec.h
> /usr/include/libavcodec/opt.h
> /usr/lib/libavcodec.so
> /usr/lib/libavcodec.so.51
> /usr/lib/libavcodec.so.51.60.0
> /usr/lib/pkgconfig/libavcodec.pc
> [david at Mandrake ~]$
>
>
>
> Then :
>
> Code:
> [david at Mandrake ~]$ urpmf libavcodec
> libffmpeg51:/usr/lib/libavcodec.so.51
> libffmpeg51:/usr/lib/libavcodec.so.51.60.0
> libffmpeg-devel:/usr/include/libavcodec
> libffmpeg-devel:/usr/include/libavcodec/avcodec.h
> libffmpeg-devel:/usr/include/libavcodec/opt.h
> libffmpeg-devel:/usr/lib/libavcodec.so
> libffmpeg-devel:/usr/lib/pkgconfig/libavcodec.pc
> libffmpeg-static-devel:/usr/lib/libavcodec.a
> libffmpeg-static-devel:/usr/lib/libavcodec/libavcodec.a
> (...)
> [david at Mandrake ~]$
>
>
> [david at Mandrake ~]$ rpm -qa | grep libffmpeg-devel
> [b]libffmpeg-devel-0.4.9-3.pre1.14161.1.1plf2009.0[/b]
> [david at Mandrake ~]$
>
>
>
> So, i deleted the CmakeCache.txt file and rerun ./configure again, and a build error again.
>
>
> Code:
> Dans le fichier inclus à partir de /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:10,
>          à partir de /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:2:
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp:10:21: erreur: avcodec.h : Aucun fichier ou dossier de ce type
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp:11:22: erreur: avformat.h : Aucun fichier ou dossier de ce type
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp:14:25: erreur: swscale.h : Aucun fichier ou dossier de ce type
> In file included from /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:2:
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:33: erreur: expected ',' or '...' before '*' token
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:33: attention : ISO C++ forbids declaration of 'AVFrame' with no type
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:130: erreur: expected ',' or '...' before '*' token
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:130: attention : ISO C++ forbids declaration of 'AVFrame' with no type
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp: In member function 'double osgFFmpeg::FFmpegClocks::videoSynchClock(int)':
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:132: erreur: 'pts' was not declared in this scope
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:145: erreur: 'time_base' was not declared in this scope
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:146: erreur: 'frame' was not declared in this scope
> /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:150: erreur: 'pts' was not declared in this scope
> make[2]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/FFmpegClocks.o] Erreur 1
> make[1]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/all] Erreur 2
> make: *** [all] Erreur 2
> [player at Mandrake ~]$
>
>
>
> Thank you
>
> ------------------
> Read this topic online here:
> http://forum.openscenegraph.org/viewtopic.php?p=7930#7930
>
>
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list