[osg-users] ffmpeg plugin on OS X / DarwinPorts

Robert Osfield robert.osfield at gmail.com
Wed Mar 4 02:14:16 PST 2009


Hi Ulrich,

On Wed, Mar 4, 2009 at 9:37 AM, Ulrich Hertlein <u.hertlein at sandbox.de> wrote:
> Tried that but it doesn't make a difference.  I am fairly convinced now that
> the symbol is simply not present in the library.

Can you list what symbols it exports?

> I understand that they want people to use swscaler but to declare it in the
> header file and not include it in the library *and* not to provide a method
> to detect this at compile time is just mean.

I've previously worked with the same ffmpeg revision as the one you
are using, but it's obviously been built differently as it does have
img_convert.    In later rev's ffmpeg drops the img_convert from the
header, but still implements it.  The swsscaler functions are also
implemented but the headers aren't installed unless you compile the
libswscale library.  It really is a bit of mess.

I find it a bit bizarre that ffmpeg seems to do a good job at what it
does but... packaging consistency really does it a disservice.

Robert.



More information about the osg-users mailing list