[osg-users] Troubles building osg_Freetype plugin

Mattias Helsing helsing72 at gmail.com
Tue Mar 3 16:35:40 PST 2009


Hello ppl,

I have just sent Dieter a zip with freetype238 compiled with msvc71.
Hope it helps. Let me know if it didn't arrive (~1.2mb)

Whats interesting is that I built it from source with newly created
cmakelists.txt inside Philip Lowman's first draft of CMakePorts as
mentioned by Luigi. This looks very promising and could make
maintaining win32 dependencies a very easy task. Kudos and whatnot to
Philip and Luigi for initiating this.

Mattias

On 3/3/09, Dieter Pfeffer <dieter.pfeffer at nl.thalesgroup.com> wrote:
> Hello Jean-Sebastien
>
> when I use your link
>
>>"VisualStudio 7.1 -
>>
> https://osgtoy.svn.sourceforge.net/svnroot/osgtoy/3rdParty/branches/3rdParty
> _win32binaries_vs71/"
>
>
> I find the freetype219.lib, but I thought I need the never version of the
> freetype (freetype235.lib?) libs.
>
>
>
> Dieter
>
>
>
>
> Unclassified Mail
>
>
> -----Original Message-----
> From: osg-users-bounces at lists.openscenegraph.org
> [mailto:osg-users-bounces at lists.openscenegraph.org]On Behalf Of
> Jean-Sebastien Guay
> Sent: Monday, 02 March, 2009 18:11
> To: osg-users at lists.openscenegraph.org
> Subject: Re: [osg-users] Troubles building osg_Freetype plugin
>
>
> Hello Ernesto,
>
>> I have downloaded the 3rdParty dependencies form here
> (http://www.openscenegraph.org/downloads/dependencies/Windows/VisualStudio7/
> 3rdParty_Win32binaries_2005_05_10.zip).
>
> That's the old 3rdparty package, which is not useful anymore because we
> need a newer version of the Freetype lib in particular, which is why
> you're getting that error.
>
> The Dependencies page clearly states where to get the dependencies for
> VS7.1 (2003):
>
> http://www.openscenegraph.org/projects/osg/wiki/Downloads/Dependencies
>
> "VisualStudio 7.1 -
> https://osgtoy.svn.sourceforge.net/svnroot/osgtoy/3rdParty/branches/3rdParty
> _win32binaries_vs71/"
>
> (Note that I removed the Visual Studio 7 item in the list, it was
> misleading since VS7 is not really supported and it linked to the old
> dependencies zip from 2005 which will not work as you discovered. The
> page should now be more accurate.)
>
> Hope this helps,
>
> J-S
> --
> ______________________________________________________
> Jean-Sebastien Guay    jean-sebastien.guay at cm-labs.com
>                                 http://www.cm-labs.com/
>                          http://whitestar02.webhop.org/
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
> ------------------------------------------------------------------------------------------------------------
> Disclaimer:
>
> If you are not the intended recipient of this email, please notify the
> sender and delete it.
> Any unauthorized copying, disclosure or distribution of this email or its
> attachment(s) is forbidden.
> Thales Nederland BV will not accept liability for any damage caused by this
> email or its attachment(s).
> Thales Nederland BV is seated in Hengelo and is registered at the Chamber of
> Commerce under number 06061578.
> ------------------------------------------------------------------------------------------------------------
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list