[osg-users] [build] make : Build error on FFmpegClocks.hpp while compiling OSG-dev

david bruyer osgforum at tevs.eu
Tue Mar 3 06:29:08 PST 2009


Hi robert,

Thanks for your interest.
First of all, i renamed the title of this thread as "build error" as you guessed. You're totally right, i have to pay attention to the correct description of what happen.

I can't compile again OSG right now but this error appeared at the 12:59 compilation. (2 hours and a half ago...)
I'l compile OSG again tomorrow morning and i'll tell you 
the result.

For the ffmpeg headers, here is the list of files and relatives paths on my system :

libffmpeg-devel :

        
Code:
‎/usr/include/libavcodec
        ‎/usr/include/libavcodec/avcodec.h
        ‎/usr/include/libavcodec/opt.h
        ‎/usr/include/libavdevice
        ‎/usr/include/libavdevice/avdevice.h
        ‎/usr/include/libavformat
        ‎/usr/include/libavformat/avformat.h
        ‎/usr/include/libavformat/avio.h
        ‎/usr/include/libavformat/rtsp.h
        ‎/usr/include/libavformat/rtspcodes.h
        ‎/usr/include/libavutil
        ‎/usr/include/libavutil/adler32.h
        ‎/usr/include/libavutil/avstring.h
        ‎/usr/include/libavutil/avutil.h
        ‎/usr/include/libavutil/base64.h
        ‎/usr/include/libavutil/common.h
        ‎/usr/include/libavutil/crc.h
        ‎/usr/include/libavutil/fifo.h
        ‎/usr/include/libavutil/intfloat_readwrite.h
        ‎/usr/include/libavutil/log.h
        ‎/usr/include/libavutil/lzo.h
        ‎/usr/include/libavutil/mathematics.h
        ‎/usr/include/libavutil/md5.h
        ‎/usr/include/libavutil/mem.h
        ‎/usr/include/libavutil/random.h
        ‎/usr/include/libavutil/rational.h
        ‎/usr/include/libavutil/sha1.h
        ‎/usr/include/libpostproc
        ‎/usr/include/libpostproc/postprocess.h
        ‎/usr/include/libswscale
        ‎/usr/include/libswscale/rgb2rgb.h
        ‎/usr/include/libswscale/swscale.h
        ‎/usr/lib/libavcodec.so
        ‎/usr/lib/libavdevice.so
        ‎/usr/lib/libavformat.so
        ‎/usr/lib/libavutil.so
        ‎/usr/lib/libpostproc.so
        ‎/usr/lib/libswscale.so
        ‎/usr/lib/pkgconfig/libavcodec.pc
        ‎/usr/lib/pkgconfig/libavdevice.pc
        ‎/usr/lib/pkgconfig/libavformat.pc
        ‎/usr/lib/pkgconfig/libavutil.pc
        ‎/usr/lib/pkgconfig/libpostproc.pc
        ‎/usr/lib/pkgconfig/libswscale.pc



Thanks for your help.
Regards
David



Robert Osfield wrote:
> HI David,
> 
> So this is a build error, not an actual program crash.  In future
> could you refer to errors like this as build errors as it'll make it
> easier for us to track the different types of problems.
> 
> While I don't understand the language the errors were in my guess is
> that the headers files haven't been found for some reason.  One
> weakness of FFmpeg is that it's packaged quite different across
> platforms, placing headers in different directories etc.  This makes
> it quite hardwork for second guess what all the different combinations
> might be.
> 
> Today I've added a few more include directories into the checks, so
> could you do an svn update and see if that fixes the problem.  If it
> doesn't  the could you post where abouts your ffmpeg package has it's
> headers installed.
> 
> Cheers,
> Robert.
> 
> On Tue, Mar 3, 2009 at 1:59 PM, david bruyer <> wrote:
> 
> > Hi,
> > 
> > Does anyone know what I could do to solve this compilation crash for OSG-dev ?
> > Here is the log :
> > 
> > 
> > Code:
> > Dans le fichier inclus à partir de /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:10,
> >          à partir de /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:2:
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp:10:21: erreur: avcodec.h : Aucun fichier ou dossier de ce type
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp:11:22: erreur: avformat.h : Aucun fichier ou dossier de ce type
> > In file included from /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:2:
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:33: erreur: expected ',' or '...' before '*' token
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.hpp:33: attention : ISO C++ forbids declaration of 'AVFrame' with no type
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:130: erreur: expected ',' or '...' before '*' token
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:130: attention : ISO C++ forbids declaration of 'AVFrame' with no type
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp: In member function 'double osgFFmpeg::FFmpegClocks::videoSynchClock(int)':
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:132: erreur: 'pts' was not declared in this scope
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:145: erreur: 'time_base' was not declared in this scope
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:146: erreur: 'frame' was not declared in this scope
> > /home/player/FlightGear-dev/build/OpenSceneGraph/src/osgPlugins/ffmpeg/FFmpegClocks.cpp:150: erreur: 'pts' was not declared in this scope
> > make[2]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/FFmpegClocks.o] Erreur 1
> > make[1]: *** [src/osgPlugins/ffmpeg/CMakeFiles/osgdb_ffmpeg.dir/all] Erreur 2
> > make: *** [all] Erreur 2
> > 
> > 
> > I have the correct libffmpeg-devel installed on my system...
> > 
> > Thank you.
> > David
> > 
> > Linux Mandriva 2009
> > 
> > ------------------
> > Read this topic online here:
> > http://forum.openscenegraph.org/viewtopic.php?p=7856#7856
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > osg-users mailing list
> > 
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > 
> > 
> _______________________________________________
> osg-users mailing list
> 
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> 
>  ------------------
> Post generated by Mail2Forum


------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=7861#7861








More information about the osg-users mailing list