[osg-users] Problem compiling latest trunk, ffmpeg problem

Robert Osfield robert.osfield at gmail.com
Mon Mar 2 06:17:29 PST 2009


Hi J.P,

On Mon, Mar 2, 2009 at 1:43 PM, J.P. Delport <jpdelport at csir.co.za> wrote:
> I have just checked my lgpl libs and it does contain img_resample. Maybe we
> can use that? Just double check your latest libs.

The present ffmpeg plugin using the deprecated img_convert method, and
this is in the libavcodec.sp of svn version of ffmpeg, as are the
sws_scale and associated methods:

nm ./libavcodec/libavcodec.so | grep img_convert
000000000008bd00 T img_convert

robert at harris:~/3rdParty/ffmpeg$ nm ./libavcodec/libavcodec.so | grep sws
000000000009ae20 T sws_freeContext
000000000009bed0 T sws_getCachedContext
000000000009bdb0 T sws_getContext
000000000009b8a0 T sws_scale

But... the installed headers don't included any of them.  So it looks
like if your app is compiled against these methods say from an older
rev of ffmpeg it will work when linking against a new rev.  But... you
can't compile against these functions without adding the headers in
some way.

> The matrix would then become:
> if (img_resample available) {
>        use it (Tanguys code)
>        do not link to swscale
> } else {
>        use swscale
>        link to swscale
> }

Perhaps another way would be to move the implementation of img_convert
directly into our plugin.

Robert.



More information about the osg-users mailing list