[osg-users] Problem compiling latest trunk, ffmpeg problem

J.P. Delport jpdelport at csir.co.za
Mon Mar 2 05:43:32 PST 2009


Hi,

Robert Osfield wrote:
> Hi J.P,
> 
> On Mon, Mar 2, 2009 at 12:34 PM, J.P. Delport <jpdelport at csir.co.za> wrote:
>> The one I compiled with LGPL only, has the sws functions in libavcodec.so.
>>
>> nm ./libavcodec/libavcodec.so | grep sws
>> 0008c1b0 T sws_freeContext
>> 0008d1f0 T sws_getCachedContext
>> 0008d0f0 T sws_getContext
>> 0008caf0 T sws_scale
> 
> I just updated my ffmpeg to latest in svn and it defines the above
> methods, but doesn't declare them in the headers.

I have just checked my lgpl libs and it does contain img_resample. Maybe 
we can use that? Just double check your latest libs.

The matrix would then become:
if (img_resample available) {
         use it (Tanguys code)
         do not link to swscale
} else {
         use swscale
         link to swscale
}

jp


-- 
This message is subject to the CSIR's copyright terms and conditions, e-mail legal notice, and implemented Open Document Format (ODF) standard. 
The full disclaimer details can be found at http://www.csir.co.za/disclaimer.html.

This message has been scanned for viruses and dangerous content by MailScanner, 
and is believed to be clean.  MailScanner thanks Transtec Computers for their support.




More information about the osg-users mailing list