[osg-users] [vpb] osgdem issue

labrosse osgforum at tevs.eu
Mon Mar 23 03:21:58 PDT 2009


Hello,

I work with OSG 2.6.1, GDAL 1.5.3 and VirtualPlanetBuilder r924 (compatible with OSG 2.6.1) on a virtual machine (fedora 10) to use osgdem. All compile correctly, but when I want to use osgdem with this command for example :

	osgdem -d ps_height_1k.tif -t ps_texture_1k.tif -o out.ive

I get this error, and I don't know what to do. I tried with the last version of OSG and VPB and I obtain the same error.

Here is my error :


> -d ps_height_1k.tif
> -t ps_texture_1k.tif
> -o out.ive
> Adding terrainTile
> DataSet::_run() 0 0
> DataSet::assignDestinationCoordinateSystem() : assigning first source file as the destination coordinate system
> started DataSet::createDestination(30)
> DataSet::assignDestinationCoordinateSystem() : assigning first source file as the destination coordinate system
> AR=1.000000 C1=1 R1=1
> createNewDestinationGraph
> Time for _destinationGraph->computeMaximumSourceResolution() = 0.013825
> Time for createDestinationGraph 0.080615
> Time for after_computeNeighbours 0.029995
> Time for consolodateRequiredResolutions 0.000003
> Time for after_reproject 0.000576
> Time for after_sort 0.000568
> completed DataSet::createDestination(30)
> There are 2 contributing source files:
>     ps_height_1k.tif
>     ps_texture_1k.tif
> Error: Unable to open display ":0.0".
> Error: Unable to open display ":0.0".
> Error: Unable to create graphis context, problem with running osgViewer-2.6.1, cannot run compression.


Precisions :  - I connect to my Virtual machine with a console (ssh -X 192.168.x.x).
                      - I think what the third error is blocking.

Sorry about my English.

Best Regards.

Fabien Labrosse

------------------
Read this topic online here:
http://forum.openscenegraph.org/viewtopic.php?p=8922#8922








More information about the osg-users mailing list