[osg-users] osgdem segmentation fault

benben benhongh at gmail.com
Thu Sep 18 06:35:19 PDT 2008

Robert Osfield wrote:
> Hi Ben,
> Thanks for the extra info.   The segfault without any options suggests
> a build issue or link issue of some kind.
> Could you provide the stack trace?

Sure, the core file reads

#0  0x00007fa215d13af2 in ?? () from /usr/lib/libGL.so.1
#1  0x00007fa216c730d9 in osgViewer::PixelBufferX11::init ()
    from /usr/lib/libosgViewer.so.6
#2  0x00007fa216c73788 in osgViewer::PixelBufferX11::PixelBufferX11 ()
    from /usr/lib/libosgViewer.so.6
#3  0x00007fa216c6fd27 in 
X11WindowingSystemInterface::createGraphicsContext ()
    from /usr/lib/libosgViewer.so.6
#4  0x000000000040ae91 in main ()

It seems it's more of a OSG/OpenGL problem than a osgdem related one. 
But I have been writing a few OSG apps and they don't seem to have any 
segfault problems. If it is in fact non-osgdem related, you have my apology.

> VPB and OSG have come along way since 0.9.1 and OSG-2.2 respectively,
> and this week I'll be make dev releases for both VPB and OSG that will
> be matched so these would be a good place to move up to.   VPB itself
> is pretty near its 1.0 status, just a few more weeks left development
> wise.

The only reason I didn't installed the lastest VPB is that I don't want 
to rebuild OSG from source. I tried, but despite my best effort to set 
environment variables I could't get it to load plug-ins. As my project 
deadline is closing in I'd play safe with the working 2.2 OSG installation.

I will give OSG2.6 / VPN1.0 a shot once my project is over.

> Robert.



> On Wed, Sep 17, 2008 at 2:58 PM, benben <benhongh at gmail.com> wrote:
>> Robert Osfield wrote:
>>> Hi Ben,
>>> I'm afraid there is waaaay too little info about your setup to provide
>>> any real guidance.  VPB should just compile against an installed OSG
>>> without need for configuration.
>>> You don't mention which VPB or OSG version your are using, you also
>>> make no mention of the platform or compilers.  All this is important
>>> to understanding what might go wrong and how to fix it.
>> Sorry for the lack of information. The OSG version is 2.2 and the VPB
>> version is 0.9.1. I am running a Ubuntu Linux 8.04 64bit on an Intel
>> platform, if this is also relevant.
>> The osg installation is straight from the Ubuntu package repository (binary
>> install, as opposed to local rebuild).
>> For building the VPB I added an extra line to the CMakeLists.txt
>>    SET(GDAL_INCLUDE_DIR /usr/include/gdal)
>> so osgdem can be compiled.
>> I followed the standard
>>   ./configure
>>   make
>>   sudo make install
>> Everything seemed to be ok. For some reason my OS does not put 64bit
>> libraries in /usr/local/lib64, where the VPB libraries are, so I
>>   export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib64
>> This stops the "cannot find shared object" error from the loader.
>> And on executing
>>   osgdem
>> with no arguments, it simply quits with a segmentation fault error.
>> I also followed the VPB tutorial at
>> http://www.openscenegraph.org/projects/VirtualPlanetBuilder
>> and despite the extra argument inputs I have the same error. So I reckon I
>> must have configured VPB wrong somehow.
>> Is there anything I overlooked?
>> Regards
>> Ben
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

More information about the osg-users mailing list