[osg-users] OpenSceneGraph Install issue

Bob Huebert huebert at arsc.edu
Fri Sep 12 15:29:41 PDT 2008

Hi Michael,

On Fri, 12 Sep 2008, Michael W. Hall wrote:

> I got the latest trunk of OpenSceneGraph.  I was having trouble with
> VPB, but I tried to run "osgversion".  When I did I got the following:
> osgversion: error while loading shared libraries: libOpenThreads.so.11:
> cannot open shared object file: No such file or directory

If this file is indeed built, make sure your LD_LIBRARY_PATH 
environment variable points to it's location.

i.e. % export LD_LIBRARY_PATH=/usr/local/lib64


> I have an AMD64 processor and Fedora Core 9 x86_64.  Could this be the
> reason my VPB is giving me this error?  I checked and the file in
> question exists.    I have tried making links from other libraries back
> to the where the files are in /usr/local/lib64.  I still get the same
> error. Any help appreciated.
> Michael
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

More information about the osg-users mailing list