[osg-users] VPB error

Michael W. Hall hallmw at att.net
Sat Sep 6 14:03:59 PDT 2008

Got OSG/trunk and VPB/trunk both compiled and both installed.  However,
I still get the error when I try to run osgdem.  

osgdem:  error while loading shared libraries:  libvpb.so.8: cannot open
shared object file:  No such file or directory

I looked in /usr/local/lib64 and here is what I have:

lrwxrwxrwx 1 root root      11 2008-09-06 15:57 libvpb.so -> libvpb.so.8
-rwxr-xr-x 1 root root 3577150 2008-09-06 15:57 libvpb.so.0.9.9
lrwxrwxrwx 1 root root      15 2008-09-06 15:57 libvpb.so.8 ->

Not sure why I am getting the error, when it appears that the install
did creat the symlink.

Any ideas?


On Fri, 2008-09-05 at 20:59 +0100, Robert Osfield wrote:
> On Fri, Sep 5, 2008 at 8:26 PM, Michael W. Hall <hallmw at att.net> wrote:
> > I looked at the front page and nothing is mentioned about OSG 2.6.
> And yet you still wanted to make the assumption that implictly
> SVN/trunk meant OSG 2.6...  the VPB wiki front page tells you
> everything that is to know.
> > I
> > have tried VPB 0.9.7 and make fails with several errors.  The SVN
> > version compiles, but gives the the error when I try to run it.  Can you
> > tell me which version of VPB I need?
> There is no VPB dev release that maps to OSG-2.6.
> VPB is in development, and isn't far away from its 1.0.  To pick up on
> the latest VPB you'll need VPB svn/trunk and OSG svn/trunk as some of
> the recent additions to VPB required mods to osgTerrain in OSG, since
> 2.6.
> Once VPB is ready for its next dev release I'll match a VPB dev
> release with a corresponding OSG dev release.  I'm not ready for this
> yet.
> Robert.
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

More information about the osg-users mailing list