[osg-users] vpb on cluster example

Greg Myers aftacer at gmail.com
Wed Jul 30 11:10:50 PDT 2008


Hey Jason,

Thanks for the reply.  I guess I'm going to have to bite the bullet
and try that out.  It just takes a substantial amount of time so I
hate to do it without knowing if I'm doing it right in the first
place.  Tell me this though, is it possible to add new images to an
existing ive file?  For instance, if I ran osgdem against just some
plain old DTED data without images and output the results to dted.ive,
could I then run another osgdem command and pass in image data using
the same dted.ive file?  Would it just add in the images to the
terrain or would it start fresh and blow away my existing terrain?

Thanks
Greg

On Jul 30, 10:43 am, "Jason Beverage" <jasonbever... at gmail.com> wrote:
> Hi Greg,
>
> I would just remove the -l command line and let vpb run as long as it needs
> to.  Depending on the level of your data, it might need to go higher than
> level 10.
>
> Thanks,
>
> Jason
>
> On Wed, Jul 30, 2008 at 1:33 PM, Greg Myers <afta... at gmail.com> wrote:
> > Hey JP,
>
> > First of all I want you to know that I really appreciate your help. :)
>
> > I tried the BMNG image that covers my area of interest and that worked
> > like a charm.  No more black areas.
>
> > Now, I only ran the data using a level setting of 10.  When I zoom in
> > on the high res image that I provided, it is not high res at all.
> > Does the level setting need to be cranked way up in order to be able
> > to see the details in the high res image?  Do I need to specify layer
> > options for my high res image like you did in your example?
>
> > And one more question, what is the purpose of the archive file output
> > type ( the -a option ) ?
>
> > Thanks
> > Greg
>
> > On Jul 30, 3:33 am, "J.P. Delport" <jpdelp... at csir.co.za> wrote:
> > > Hi,
>
> > > sorry, I can only guess at potential problems...
>
> > > I am assuming you are viewing the data with osgviewer so that I can
> > > discard other cases where blending might not be set up correctly.
>
> > > The black portions normally indicate that something is up with the
> > > blending of data. E.g. sometimes the geotiffs have transparent areas
> > > that have to be blended with other tiles. This occurs e.g. when the
> > > tiles are not square. Since the dted data has no colour data, I'm not
> > > sure what the image data will blend with.
>
> > > What I would try is to use one of the BMNG tiles as a backdrop. See on
> > > the wiki for a link. The BMNG tile covers a wide area and would be used
> > > for places in the terrain where you do not supply your own higher res
> > > image data.
>
> > > jp
>
> > > GregMyerswrote:
> > > > I have another question for you JP.  I have been playing with the
> > osgdem
> > > > tool and trying to create a terrain database with some aerial photos (
> > > > geotiffs ).  After my database is generated using the command:
>
> > > > Osgdem --geocentric --terrain -d DTED -t image.tif -l 4 -o
> > test\test.ive
>
> > > > I get something that looks about right except that the terrain around
> > the
> > > > image is blacked out.  More area is blacked out when I'm viewing the
> > higher
> > > > layers.  I'm attaching a small image so that you can see what I'm
> > talking
> > > > about.  If you look near the top left corner of the black area you can
> > > > barely make out my tiny little geotiff image.  When I zoom out the
> > black
> > > > area becomes larger.  When I zoom in it becomes smaller but never goes
> > > > completely away.  It seems that whichever tile ( I think that's the
> > right
> > > > term ) the image is located in is blacked out everywhere except where
> > the
> > > > image is.  Is it not possible to use images that only cover a portion
> > of
> > > > your terrain or am I just missing some command line arguments or
> > something?
>
> > > > Thanks
> > > > Greg
>
> > > > -----Original Message-----
> > > > From: osg-users-boun... at lists.openscenegraph.org
> > > > [mailto:osg-users-boun... at lists.openscenegraph.org] On Behalf Of J.P.
> > > > Delport
> > > > Sent: Monday, July 28, 2008 11:49 PM
> > > > To: OpenSceneGraph Users
> > > > Subject: Re: [osg-users] vpb on cluster example
>
> > > > Hi,
>
> > > > GregMyerswrote:
> > > >> Hi JP,
>
> > > >> I'm new and I'm a little fuzzy on the versioning between VPB and OSG.
> > > >> It looks like for the example you have provided, we need an older
> > > >> version (2.3.6) of OSG.  Do you know if there are plans to upgrade VPB
> > > >> to work with the latest releases of OSG or am I totally missing
> > > >> something?
>
> > > >> Thanks for any info.
> > > >> Greg
>
> > > > sorry, I should have made the versions I used more explicit. For the
> > > > example I used OSG and VPB from svn around June.
>
> > > > osgversion says 2.5.1.
>
> > > > svn info gives:
> > > > Revision: 8413 for OSG
> > > > and
> > > > Revision: 914 for VPB
>
> > > > I'll add the info to the example page.
>
> > > > regards
> > > > jp
>
> > ------------------------------------------------------------------------
>
> > ------------------------------------------------------------------------
>
> > > > _______________________________________________
> > > > osg-users mailing list
> > > > osg-us... at lists.openscenegraph.org
> > > >http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.
> > ..
>
> > > --
> > > This message is subject to the CSIR's copyright terms and conditions,
> > e-mail legal notice, and implemented Open Document Format (ODF) standard.
> > > The full disclaimer details can be found athttp://
> >www.csir.co.za/disclaimer.html.
>
> > > This message has been scanned for viruses and dangerous content by
> > MailScanner,
> > > and is believed to be clean.  MailScanner thanks Transtec Computers for
> > their support.
>
> > > _______________________________________________
> > > osg-users mailing list
> > > osg-us... at lists.openscenegraph.orghttp://
> > lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph...
> > _______________________________________________
> > osg-users mailing list
> > osg-us... at lists.openscenegraph.org
> >http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph...
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-us... at lists.openscenegraph.orghttp://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph...



More information about the osg-users mailing list