[osg-users] Slave Cameras projection matrices and aspect ratio

Robert Osfield robert.osfield at gmail.com
Thu Jul 24 03:12:08 PDT 2008


Hi Joseanibal,

Could you provide a Producer .cfg that you are having problem with.
Could you also please specify which versions of the OSG you've tried.

Robert.

On Thu, Jul 24, 2008 at 3:43 AM, Joseanibal Colon Ramos
<jcolon at email.arc.nasa.gov> wrote:
> Hi Anyone,
>
> I need to fix this ASAP. I am using OSG 2.4+ with old Producer Config
> files. OSG creates slave cameras for my multiple window configuration (one
> for each). The resulting settings are not quite like specified in my
> configuration file. Field of Views are mostly OK, but it is altering the
> aspect ratios of the slave cams and providing me with an image slightly
> off from how it should be. I've tried setting the Slave cams' projection
> matrix, (setProjectionMatrixAsPerspective) with particular aspect ratios
> etc, but the aspect ratio value is being overriden somewhere and adjusted
> a little bit. However, the Master cam's aspect ratio is correct. How do I
> correctly set the Slave cam's aspect ratios?? and Why are the Producer
> Configuration files not doing what they used to in OSG 1.2  ?? Anyone
> please let me know soon, THANKS!
>
> -JCOLON
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list