[osg-users] Problems resizing the screen

Robert Osfield robert.osfield at gmail.com
Sat Jul 19 12:39:38 PDT 2008


HI Hugo,

Are you recreating the GraphicsWindow(s) after the window resize?  The
OSG doesn't have mechanism for automatically updating any existing
windows after a windowing system resolution change so you'll need to
update the windows manually.  The design is such that one would
normally set the resolution, then create the windows.  A simple way to
do this might be to have two viewers - one for your intro, then you
close this, resize the window then start you main sim viewer.

Robert.

On Sat, Jul 19, 2008 at 6:17 PM, Hugo Gomes <mr.hugo.gomes at gmail.com> wrote:
> Hello,
>
> im having problems resizing the screen.
>
> I start up a osgViewer::Viewer, with a menu scene for the user to select a
> proper resolution before simulation starts.
> When the user presses "start" in the menu, i set the done flag to true (to
> escape the main loop), resize the screen (if necessary), set scene data with
> a loader, setup the viewport with the resolution, and adjust the modelview
> for the given aspect ratio, and set the done flag to false and enterin again
> in the loop (viewer->frame()).
>
> To resize im using the osg::GraphicsContext::WindowingSystemInterface. Which
> works fine. The problem is the output i get whenever i choose a different
> resolution than the one im using:
>
> http://img180.imageshack.us/my.php?image=artifactsafterresizepm1.png
>
>
>
> What is happening ? Am i forgeting something ?
>
> Thanks
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list