[osg-users] Plugin Problem, osgDB doesn't find plugins

James Dickson james.dickson at gmail.com
Fri Jul 18 13:46:24 PDT 2008


Hi,

I managed to get osg working under VS2008 with all the plugins (i can run
every example with no errors about plugins). Here is what I did, it may not
be any different from what you have already done:

Under the folder F:\Src\Osg I have:
3rdParty
OpenSceneGraph
OpenSceneGraph-data ->
http://www.openscenegraph.org/files/OpenSceneGraph-2.4.0/OpenSceneGraph-Data-2.4.0.zip
 (extracted)

3rdParty is a copy of the svn repo:
http://osgtoy.svn.sourceforge.net/svnroot/osgtoy/3rdParty/branches/3rdParty_win32binaries_vs80sp1
OpenSceneGraph is a copy of the svn repo:
http://www.openscenegraph.org/svn/osg/OpenSceneGraph

3rdParty looks like:
3rdParty\bin
3rdParty\data
3rdParty\include
3rdParty\etc...

OpenSceneGraph looks like:
OpenSceneGraph\applications
OpenSceneGraph\Build <- CMake creates all the files in here for VS.
OpenSceneGraph\CMakeModules
OpenSceneGraph\etc...

I run CMake and locate the OpenSceneGraph folder. Hit the configure button,
set every option that is "ON or OFF" to ON. Hit configure again, OK is then
enabled and the VS files are produced in OpenSceneGraph\Build.

I have envrioment variables then as follows: (I set them as both System and
User variables)
OSG_FILE_PATH = F:\Src\osg\OpenSceneGraph-Data
PATH = {all other paths}
F:\Src\osg\OpenSceneGraph\Build\bin\;F:\Src\osg\OpenSceneGraph\Build\bin\osgPlugins-2.5.3\

On occasion I have found that a restart is required for the enviroment
variables to be picked up.

With all that done I then just compile the OpenSceneGraph.sln in the build
folder having converted the solution to a VS2008 project.

I hope that helps. :-)
James




2008/7/18 Ariasgore <ariasgore at gmx.de>:

> Hi,
>
> the compiling part seems to be tricky for me, I tried to compile jpeg, got
> the zip but since there is no vs project in there, I tried that by hand (and
> reading the install doc) which was less than succesfull.
>
> Pretty akward to get the 3rd party libs.
>
> Greets
>
> --------------------------------------------------
> From: "Jean-Sébastien Guay" <jean-sebastien.guay at cm-labs.com>
> Sent: Friday, July 18, 2008 8:15 PM
> To: "OpenSceneGraph Users" <osg-users at lists.openscenegraph.org>
> Subject: Re: [osg-users] Plugin Problem, osgDB doesn't find plugins
>
>   Hello Ariasgore,
>>
>> This is not a linking error that must be fixed in the project, am i right?
>>> This is a missing dll as i suppose...
>>>
>>
>> You didn't say if you compiled the 3rdParty dependencies yourself or not.
>> If you didn't do that, then stop trying other things and do that. It will
>> eliminate the most likely reason that the plugins don't load. Re-read my
>> previous message.
>>
>> The problem is that when dynamically loading a plugin, the error message
>> is the same if the plugin is *not found* and if the plugin *could not be
>> loaded*. I suspect that in your case, the latter is what's happening. And
>> this could be caused by (among other things) the fact that the plugins'
>> dependencies (libjpegD.lib in your case) were compiled with a different
>> compiler than the plugins themselves.
>>
>> Good luck,
>>
>> J-S
>> --
>> ______________________________________________________
>> Jean-Sebastien Guay    jean-sebastien.guay at cm-labs.com
>>                               http://www.cm-labs.com/
>>                        http://whitestar02.webhop.org/
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



-- 
James Dickson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080718/5b383a7d/attachment-0003.htm>


More information about the osg-users mailing list