[osg-users] PrecipitationEffect not updating

Robert Osfield robert.osfield at gmail.com
Fri Jul 18 01:35:04 PDT 2008


Hi Murray,

Does osgprecipitation work fine?

As for what might be missing from update in your case, well you have
the source code.  BTW you can set your own UpdateVisitor if you wish
via viewer.setUpdateVisitor(mySubclassedFromUpdateVisitorObject);

Robert.

On Fri, Jul 18, 2008 at 2:23 AM, Murray Curtis <murray at dragtag.com.au> wrote:
> I'm having trouble getting osgParticle::PrecipitationEffect to update. I get
> particles that just sit stationary in mid air but they do die (fade off)
> after a few seconds.
>
> I added an update callback to the precipitation node and can confirm its
> getting a valid (updating) framestamp.
>
> I'm using a composite viewer with two views in a shared graphics context. I
> don't use the viewers run() method but I do run an update traversal (
> _primaryRoot.get()->accept(updateVisitor);) as confirmed by the callback
> above.
>
> Is there another part of the update I'm missing?
>
> A trivial test program:
>
>    precipitationEffect = new osgParticle::PrecipitationEffect;
>    group->addChild(precipitationEffect.get());
>    viewer.run();
>
> works perfectly.
>
> I'm using OSG 2.5.4 on Linux.
>
> Any pointers much appreciated.
>
> Murray Curtis
> Tag Systems
> Melbourne
> Australia
>
> (Irony: We're in the worst drought in Australia's recorded history and its
> raining for real outside...)
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list