[osg-users] 回复: Re: multi translucent geometry

小 杨 ygwbjut at yahoo.com.cn
Sun Jul 13 18:06:20 PDT 2008


Thanks! I'll try it!

Peter Wraae Marino <osghelp at gmail.com> 写道:    Hi ?? (can't see your name),
   
  Are you sure zbuffer isn't falling for your 2nd geometry object? Also
  having equal depths is probably not a good idea? You need to render your
  objects from back to front order.
   
  When you have transparent objects you should set the stateset 
    stateset->setRenderBinDetails(10,"DepthSortedBin");

  this will render the objects from back to front order...
  but note they will not sort the polygons for the individual
  geometry.
   
  

 
  2008/7/13 小 杨 <ygwbjut at yahoo.com.cn>:
    multi  translucent geometry   with equal depth but  alpha value is not equal.
   
  when i render these geometry ,i can not see all geometry! Why ?
   
  Can everyone give me some advice! 
   
  Thanks! 
    
---------------------------------
  雅虎邮箱,您的终生邮箱!   

_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

  




-- 
Regards,
Peter Wraae Marino

www.osghelp.com - OpenSceneGraph support site _______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org


       
---------------------------------
 雅虎邮箱,您的终生邮箱!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080714/2a15529d/attachment-0003.htm>


More information about the osg-users mailing list