[osg-users] --subtile option for osgdem working?

Nolan Wester nlwester at gmail.com
Fri Jul 11 17:11:33 PDT 2008


Robert,

Is there a way to tell osgdem to generate less triangles while keeping high
resolution texture? For example, say I only want to generate the amount of
triangles equivalent to what would be generated by osgdem in level 3. But I
want the texture in that resulting terrain to reach full resolution.

If I use:

osgdem <...> -l 3

then I will get the limited number of triangles as desired, but the texture
will be very low resolution.

Thanks
-N

On Thu, Jul 10, 2008 at 12:07 PM, Robert Osfield <robert.osfield at gmail.com>
wrote:

> Hi Nolan,
>
> The sutile parameters is used during distributed/incremental builds
> run by vpbmaster, it's not something you will use in normal osgdem
> usage.
>
> Robert.
>
> On Thu, Jul 10, 2008 at 6:41 PM, Nolan Wester <nlwester at gmail.com> wrote:
> > Greetings,
> >
> > Is the --subtile option for osgdem working properly? It seems to be
> > counting incorrectly when I use it. For example, --subtile 2 0 0
> > generates only one tile when in fact there should be subtiles 2 0 1, 2
> > 0 2, 2 1 0, ... Using --subtile 1 0 0 ends up generating more tiles
> > for level 2 but even that misses some.
> >
> > This is with osgdem 0.9.8
> >
> > Thank you,
> > Nolan
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080711/1564e021/attachment-0003.htm>


More information about the osg-users mailing list