[osg-users] Cygwin compiled version from Svn will only load and convert osg files and not gif files - any thoughts?

Brian Keener brianklistacct at alltel.net
Thu Jul 10 22:01:07 PDT 2008


Jean-Sébastien Guay wrote:
> > It may be a 
> > far jump but my thoughts are this leads us down the path that it there is 
> > possibly something either in the osg plugin or more likely - the 3d 
> > functionality and the extra logic and threads needed to accomplish the 3d 
> > display.
> 
> You seem to think that osgviewer with or without --image does radically 
> different things... It doesn't. It's the same viewer, the same setup. It 
> will detect and use the same thread config, etc. When you do
> 
> osgviewer --image bob.jpg
> 
> it creates a quad (in 3D space) and maps your image onto it as a 
> texture. So it's still displaying a model in 3D.

You are correct I was thinking there was a major difference - dang - back to 
the grind stone :-(

> Yes, it may be the .osg 
> loader, but it may be something totally unrelated. You just haven't 
> presented enough information to be able to make that call at this point.

I thought it was too big a jump and it was :-(
 
> I think you just need to start with basics. Compile OSG and osgviewer in 
> debug mode, start it in gdb and recreate your crash on exit. That will 
> give you a stack trace. From that you can try to debug further or post 
> the trace here to see if we can spot something. (note that getting a 
> stack trace is the first step to debug any crash)

I've been doing that all along (using gdb) but the backtraces don't seem to 
show what is holding up the program closing.  The final error from gdb is (as 
best I recall late a night) a SIGINT due to a timeout waiting on a close while 
it is trying to close the osg plugin but I will get the exact.

bk






More information about the osg-users mailing list