[osg-users] Quicktime osgplugin compile error with eclipse + mingw

Philip Lowman philip at yhbt.com
Thu Jul 3 04:59:48 PDT 2008


On Thu, Jul 3, 2008 at 4:40 AM, Andrea Martini <martini.andrea at gmail.com>
wrote:

> Hi Philip,
> thank for your answer. I have searched gl.h include file in my fyle system,
> and i get this include file both in c:\mingw\include and visual studio path
> directory.
> Gl.h comes from visual studio directory contains the extension GL_BGRA_EXT
> and gl.h that comes from mingw has not.
> If i compile osg plugins with visual studio i have no problem.
> So i suppose that mingw must be updated with new opengl include and
> library.
> I have tried to use gl.h and glext.h from visual studio folder in mingw,
> but mingw gives me error!
> How i can update mingw to get the right gl extension?
> I have an nvidia quadro fx 4600 on window xp.
>

I'm not sure.  You might want to check with the MinGW people on this one.  I
have no idea why their gl.h doesn't expose the extension.

If you get no resolution on this from them there is always the possibility
of fixing this with a software workaround.  I assume you actually need the
quicktime plugin for something in your application?  Another possibility is
of course to simply disable building the quicktime plugin.

-- 
Philip Lowman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080703/e5c483b1/attachment-0003.htm>


More information about the osg-users mailing list