[osg-users] Testing of OSG and VPB SVN in prep for 2.5.3devreleasese

Gerrick Bivins gbivins at objectreservoir.com
Wed Jul 2 11:02:49 PDT 2008


Ok. I¹ll try the bundled flag again once I see the change is submitted.
Thanks.
Gerrick


On 7/2/08 12:58 PM, "Eric Sokolowsky" <esok.osg at gmail.com> wrote:

> 
> 
> On Wed, Jul 2, 2008 at 11:42 AM, Robert Osfield <robert.osfield at gmail.com>
> wrote:
>> Hi Gerrick,
>> 
>> I have never built VPB under OSX, and have to defer to developers that
>> work under OSX for fixes/direction on that platforms.  What I have
>> done is to try and mirror some of the changes that have being going
>> into to core OSG to help with the OSX build side, but I don't have any
>> first hand experience of testing it yet.
>> 
>> I do have an G4 on loan, so I do plan to get this machine setup and
>> test builds against it.  I will still need direction on OSX issues,
>> though, as I'm no expert on this platform.
> 
> This has been fixed in the OSG hierarchy in CMakeModules/OsgMacroUtils.cmake
> by replacing:
> 
> INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION
> share/OpenSceneGraph/bin)
> 
> with:
> 
> IF(APPLE)
>   INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION
> share/OpenSceneGraph/bin BUNDLE DESTINATION share/OpenSceneGraph/bin)
> ELSE(APPLE)
>   INSTALL(TARGETS ${TARGET_TARGETNAME} RUNTIME DESTINATION
> share/OpenSceneGraph/bin)
> ENDIF(APPLE)
> 
> You can also just use:
>   cmake_policy(SET CMP0006 OLD)
> but this just masks the warning without really fixing the problem.
> -Eric
>  
>> 
>> 
>> Robert.
>> 
>> On Wed, Jul 2, 2008 at 4:19 PM, Gerrick Bivins
>> <gbivins at objectreservoir.com> wrote:
>>> > Hi All,
>>> > I thought I'd try to build VPB and I ran into this error (on MacOSX 10.5.3
>>> > with OSG svn):
>>> >
>>> > CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
>>> >  Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
>>> >  BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
>>> details.
>>> >  se the cmake_policy command to set the policy and suppress this warning.
>>> >  Call Stack (most recent call first):
>>> >   applications/osgdem/CMakeLists.txt:9 (SETUP_APPLICATION)
>>> >  This warning is for project developers.  Use -Wno-dev to suppress it.
>>> >
>>> >
>>> >  CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
>>> >   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
>>> >   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
>>> > details.
>>> >   Use the cmake_policy command to set the policy and suppress this
>>> warning.
>>> >  Call Stack (most recent call first):
>>> >   applications/vpbcache/CMakeLists.txt:9 (SETUP_APPLICATION)
>>> >  This warning is for project developers.  Use -Wno-dev to suppress it.
>>> >
>>> >
>>> >  CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
>>> >   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
>>> >   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
>>> > details.
>>> >   Use the cmake_policy command to set the policy and suppress this
>>> warning.
>>> >  Call Stack (most recent call first):
>>> >   applications/vpbsizes/CMakeLists.txt:9 (SETUP_APPLICATION)
>>> >  This warning is for project developers.  Use -Wno-dev to suppress it.
>>> >
>>> >
>>> >  CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
>>> >   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
>>> >   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
>>> > details.
>>> >   Use the cmake_policy command to set the policy and suppress this
>>> warning.
>>> >  Call Stack (most recent call first):
>>> >   applications/vpbmaster/CMakeLists.txt:9 (SETUP_APPLICATION)
>>> >  This warning is for project developers.  Use -Wno-dev to suppress it.
>>> >
>>> >
>>> > I have VPB_BUILD_APPLICATION_BUNDLES enabled...Turning that option off
>>> makes
>>> > the error go away. Is VPB not supposed to run as a bundled application?
>>> > biv
>>> >
>>> >
>>> >
>>> >
>>> >
>>> >
>>> >
>>> >
>>> >
>>> > CMake produced the following output
>>> >
>>> > CMake Version 2.6 - patch 0
>>> > Press [e] to exit help
>>> >
>>> >
>>> >
>>> >
>>> > On 7/2/08 7:51 AM, "Jean-Sébastien Guay" <jean-sebastien.guay at cm-labs.com>
>>> > wrote:
>>> >
>>>> >> Hi Adrian,
>>>> >>
>>>>> >>> osgshaders.exe
>>>>> >>> osgthirdpersonview.exe
>>>>> >>>
>>>>> >>> hangs on exit.
>>>> >>
>>>> >> I can't reproduce that hang. Any chance you could give a stack trace?
>>>> >>
>>>> >> J-S
>>> >
>>> > _______________________________________________
>>> > osg-users mailing list
>>> > osg-users at lists.openscenegraph.org
>>> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>> >
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> 
>> 
>> 
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20080702/6237cb8e/attachment-0003.htm>


More information about the osg-users mailing list