[osg-users] Testing of OSG and VPB SVN in prep for 2.5.3devreleasese

Gerrick Bivins gbivins at objectreservoir.com
Wed Jul 2 08:19:45 PDT 2008


Hi All,
I thought I'd try to build VPB and I ran into this error (on MacOSX 10.5.3
with OSG svn):

CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
  Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
 BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy details.
 se the cmake_policy command to set the policy and suppress this warning.
 Call Stack (most recent call first):
   applications/osgdem/CMakeLists.txt:9 (SETUP_APPLICATION)
 This warning is for project developers.  Use -Wno-dev to suppress it.


 CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
details.
   Use the cmake_policy command to set the policy and suppress this warning.
 Call Stack (most recent call first):
   applications/vpbcache/CMakeLists.txt:9 (SETUP_APPLICATION)
 This warning is for project developers.  Use -Wno-dev to suppress it.


 CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
details.
   Use the cmake_policy command to set the policy and suppress this warning.
 Call Stack (most recent call first):
   applications/vpbsizes/CMakeLists.txt:9 (SETUP_APPLICATION)
 This warning is for project developers.  Use -Wno-dev to suppress it.


 CMake Warning (dev) at CMakeModules/VpbMacroUtils.cmake:215 (INSTALL):
   Policy CMP0006 is not set: Installing MACOSX_BUNDLE targets requires a
   BUNDLE DESTINATION.  Run "cmake --help-policy CMP0006" for policy
details.
   Use the cmake_policy command to set the policy and suppress this warning.
 Call Stack (most recent call first):
   applications/vpbmaster/CMakeLists.txt:9 (SETUP_APPLICATION)
 This warning is for project developers.  Use -Wno-dev to suppress it.


I have VPB_BUILD_APPLICATION_BUNDLES enabled...Turning that option off makes
the error go away. Is VPB not supposed to run as a bundled application?
biv









CMake produced the following output
                   
CMake Version 2.6 - patch 0
Press [e] to exit help




On 7/2/08 7:51 AM, "Jean-Sébastien Guay" <jean-sebastien.guay at cm-labs.com>
wrote:

> Hi Adrian,
> 
>> osgshaders.exe
>> osgthirdpersonview.exe
>> 
>> hangs on exit.
> 
> I can't reproduce that hang. Any chance you could give a stack trace?
> 
> J-S




More information about the osg-users mailing list