[osg-users] Performance hit caused by porting from VS 7.1 to VS 9

Robert Osfield robert.osfield at gmail.com
Wed Jul 2 00:33:50 PDT 2008


Hi Rick,

Do the express editions do full optimizations?  I recall previously MS
used to cap the optimization on the give away versions of VS.

Robert.

On Tue, Jul 1, 2008 at 10:13 PM, Rick Pingry <rick at fringe-online.com> wrote:
> Hello All,
>
> We have succesfully ported from OSG 1.2 to the newest SVN version (well,
> almost newest, I think we are on 8512 at the moment).  Thanks again for all
> the fantastic forum support.
>
> We have been using VS 7.1 for all of our work so far, but since we were
> missing a well build freetype library, I figured it was time to make the
> jump there as well.  I downloaded VS 9 express and ran CMake to build OSG.
> All built just fine.  The converter in VS 9 converted all of the projects
> without fuss, and I was able to get it all compiling and running pretty
> easily.  Unfortunately, I am seeing this 30% drop in framerate :(.  I was
> seeing about 28-30 fps (yes, I know, I have some scene optimizing to do)
> with the VS 7.1 build, which dropped to 20-21 fps using VS 9 express.
>
> Has anyone seen anything like that before?  Am I missing some setting
> somewhere?  Perhaps the converter in VS 9 does not like me?
> Any ideas?
>
> -- Thanks
>>> Rick
> Check us out at http://fringe-online.com/
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list