[osg-users] OSG2.4 and 2.5.5 Windows static build problems

Christiansen, Brad Brad.Christiansen at thalesgroup.com.au
Mon Jul 21 00:46:12 PDT 2008


Hi,

I have searched the archive but cant find any mention of the problem,
though I think can remember reading about a solution some time ago on
the list.

I have just tried to build the static version of OSG v2.4 and v2.5.5
using ViualStudio .Net 2003. When I do this build I get 5000+ warnings
about dulpicate definitions when linking (LNK 4006). I then cannot link
my aplication against the resulting .libs. Has anyone else encountered
this problem and have a fix / workaround?

The same versions worked fine on my CentOS5 machine.

Cheers,

Brad



DISCLAIMER:---------------------------------------------------------------------------
This e-mail transmission and any documents, files and previous e-mail messages
attached to it are private and confidential. They may contain proprietary or copyright
material or information that is subject to legal professional privilege. They are for
the use of the intended recipient only.  Any unauthorised viewing, use, disclosure,
copying, alteration, storage or distribution of, or reliance on, this message is
strictly prohibited. No part may be reproduced, adapted or transmitted without the
written permission of the owner. If you have received this transmission in error, or
are not an authorised recipient, please immediately notify the sender by return email,
delete this message and all copies from your e-mail system, and destroy any printed
copies. Receipt by anyone other than the intended recipient should not be deemed a
waiver of any privilege or protection. Thales Australia does not warrant or represent
that this e-mail or any documents, files and previous e-mail messages attached are
error or virus free.
--------------------------------------------------------------------------------------




More information about the osg-users mailing list