[osg-users] back from a break, rookie mistake I am sure.

Anders Backman andersb at cs.umu.se
Sat Sep 29 07:34:13 PDT 2007


I sometime get these kind of errors if I link against release libraries (
osg.lib osgdb.lib) when my app is built in debug mode.
Especially osgText.lib is generating this problem.

/Anders



On 9/29/07, Philip Hahn <everphilski at gmail.com> wrote:
>
> Good Morning,
>
> Yes, I am using Multi-Threaded Debug DLL (/MDd)
>
> I'm using the pre-built Win32 version of OSG from the OSG website.
>
> I'm running a 64 bit machine on a 64 bit OS but generating 32 bit code
> with my compiler so this should be OK, right?
>
> Otherwise I will try re-building OSG locally, I was running into some
> problems with CMake last night, maybe I can get those worked out.
>
> Thanks again Robert and Sherman,
>
> Philip Hahn
>
>
> On 9/29/07, sherman wilcox <wilcox.sherman at gmail.com> wrote:
> >
> > Yes, double check which runtime you're using.
> >
> > "Project" => "Properties" => "C/C++" => "Code Generation" : Runtime
> > Library
> >
> > In most cases this should be Multi-threaded DLL (/MD) or
> > Multi-threaded Debug DLL (/MDd)
> >
> > On 9/29/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> > > Hi Philip,
> > >
> > > The looks like a build/linking error or some sort.  I'm no windows
> > > users so can't pinpoint directly, but build options are the place to
> > > look, or just double checking you aren't linking to plugins are
> > > runtime that were built with a different version of the OSG.
> > >
> > > This problem isn't related to your code, or the OSG code so don't both
> > > trying to debug it... just fix the above problems.
> > >
> > > Robert.
> > >
> > > On 9/29/07, Philip Hahn < everphilski at gmail.com> wrote:
> > > > Good Evening-
> > > >
> > > > My OSG is a little rusty as I haven't touched it in half a year now,
> > but I'm
> > > > trying to put together a very simple visualization of a simulation.
> > The code
> > > > simply loads a few models, an input file, and moves the models
> > through the
> > > > commands in the input file. If I try the following single line of
> > code:
> > > >
> > > > osg::Node* node = osgDB::readNodeFile(" cow.osg");
> > > >
> > > > I get a
> > > >
> > > > "Unhandled exception at ... in sim.exe: Microsoft C++ exception:
> > > > std::bad_alloc at memory location ..."
> > > >
> > > > This occurs in inline osg::Node* readNodeFile(), line 107 of read
> > file.
> > > >
> > > > cow.osg is in my OSG_FILE_PATH. So besides having the OSG_FILE_PATH
> > correct
> > > > is there anything else I am forgetting? The demos seem to work fine.
> > > > (Windows XP x64, MSVC v9)
> > > >
> > > > Thanks,
> > > >
> > > > Philip Hahn
> > > >
> > > > _______________________________________________
> > > > osg-users mailing list
> > > > osg-users at lists.openscenegraph.org
> > > >
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > > >
> > > >
> > > _______________________________________________
> > > osg-users mailing list
> > > osg-users at lists.openscenegraph.org
> > >
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> >
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>


-- 


________________________________________________________________
Anders Backman               Email:    andersb at cs.umu.se
HPC2N/VRlab                  Phone:    +46 (0)90-786 9936
Umea university              Cellular: +46 (0)70-392 64 67
S-901 87 UMEA SWEDEN         Fax:      +46 90-786 6126
                               http://www.cs.umu.se/~andersb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20070929/7c33353d/attachment-0003.htm>


More information about the osg-users mailing list