[osg-users] I still have 2 build issues (unices)

Robert Osfield robert.osfield at gmail.com
Fri Sep 28 12:00:28 PDT 2007


HI Andy,

There hasn't been any fix submitted for this issue.

Robert.

On 9/28/07, Andy Skinner <Andy.Skinner at mathworks.com> wrote:
>
>
>
>
> Did this get resolved?  I am seeing the same thing with 2.1.12.
>
>
>
> Actually, I don't see it when I build by hand, and I do when I build in our
> automatic build farm.  Hmmm.
>
>
>
> If this is resolved, what was the fix?  Maybe that'll narrow down what the
> problem is here.
>
>
>
> thanks,
>
> andy
>
>
>
>  ________________________________
>
>
> From: osg-users-bounces at lists.openscenegraph.org
> [mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Mike Logan
>  Sent: Thursday, September 13, 2007 7:15 PM
>  To: OpenSceneGraph Users
>  Subject: Re: [osg-users] I still have 2 build issues (unices)
>
>
>
>
> Ok, so its seems to be just macs then.
>
>
> Linux dependencies seem fine.
>
>
>
>
>
>
> Maybe my problem is related to the previous thread
>
>
>  on Tessellator and Mac builds..
>
>
>
>
>
>
>
>
> ml
>
>
>
>
>
>
>
>
>
> On Sep 13, 2007, at 4:04 PM, Mike Logan wrote:
>
>
>
>
>
>
> So, using lastest svn..
>
>
>
>
>
>   I have 4 builds, all 'out-of-source'
>
>
>           like:      OpenSceneGraph/linux32,   OpenSceneGraph/linux64, etc..
>
>
>
>
>
>
>
>
> 1)  When I  want to update the config, I sit in one of those dirs
>
>
>           and     'ccmake .."   (two dots)
>
>
>
>
>
>      I changed  BUILD_OSG_EXAMPLES:BOOL=ON
>
>
>       and when i did 'make'  it  started rebuilding the entire OSG.   Why?
>
>
>
>
>
> 2)   AFter a while, this working build now compile fails in Tessellator.cpp:
>
>
>
>
>
> /Volumes/viz/OpenSceneGraph/src/osgUtil/Tessellator.cpp: In
> member function 'void
> osgUtil::Tessellator::beginTessellation()':
>
>
> /Volumes/viz/OpenSceneGraph/src/osgUtil/Tessellator.cpp:44:
> error: invalid conversion from 'GLvoid (*)(...)' to 'GLvoid (*)()'
>
>
> .
>
>
> .
>
>
>        NO source code changed,  just  config & generate.
>
>
>
>
>
> I've seen this error before in other posts, but it seemed resolved.
>
>
> Something evil is happening,   no code changes and 2nd
>
>
>  make results in a build fail..
>
>
>
>
>
> I suspect there is still some leftover side effect of multiple platform
>
>
>  builds happening, even out-of-source, but I don't understand it yet..
>
>
>
>
>
> ml
>
>
>
>
>
>
>
>
>
>
>
> Michael Logan
>
>
> Perot Systems Govt. Services / NASA Ames Res. Ctr.
>
>
> Task Lead / Visual Cueing & Simulation
>
>
> Visualization Engineer / Adaptive Control Technologies
>
>
> MS 269-1, Moffett Field, CA, 94035  (650)-604-4494
>
>
>
>
>
>
> "If you want to start a revolution, don't pick up a gun.
>
>
>  Do it with science and technology."  - Stanford R. Ovshinsky
>
>
>
>
>
>
>
>
> _______________________________________________
>
>
> osg-users mailing list
>
>
> osg-users at lists.openscenegraph.org
>
>
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
>
>
> Michael Logan
>
> Perot Systems Govt. Services / NASA Ames Res. Ctr.
>
> Task Lead / Visual Cueing & Simulation
>
> Visualization Engineer / Adaptive Control Technologies
>
> MS 269-1, Moffett Field, CA, 94035  (650)-604-4494
>
>
>
>
>
>
> "If you want to start a revolution, don't pick up a gun.
>
>
>  Do it with science and technology."  - Stanford R. Ovshinsky
>
>
>
>
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list