[osg-users] Redistribute OSG on Vista

Fábio Mierlo geromao at gmail.com
Thu Sep 27 10:12:18 PDT 2007


You can't static link this libs?

On 9/27/07, Roger James <roger at beardandsandals.co.uk> wrote:
>
>
>
>
> Does your app need MFC? The redist installs assemblies for that as well.
>
>
>
> Do the versions in the manifest file match the ones in the dlls and the ones
> in the manifests embedded in the exe and plugin dlls?
>
>
>
> I found this thread useful
>
>
>
> http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=164465&SiteID=1
>
>
>
>
>
> osg loads its plugins via loadlibrary (as opposed to implicit loading via
> the exe loader) which is why you need private assemblies in the plugin
> directory as well.
>
>
>
> Only ms could dream up something this Byzantine!
>
>
>
> I found the ms dependency walker (http://www.dependencywalker.com) and the
> CFF Explorer (http://www.ntcore.com/products.php) useful in
> tracking this stuff down.
>
>
>
> Roger
>
>
>
>
>
>
>  ________________________________
>
>
> From: osg-users-bounces at lists.openscenegraph.org
> [mailto:osg-users-bounces at lists.openscenegraph.org] On
> Behalf Of Serge Lages
>  Sent: 27 September 2007 11:04
>  To: OpenSceneGraph Users
>  Subject: Re: [osg-users] Redistribute OSG on Vista
>
>
>
>
> On 9/27/07, Adrian Egli <3dhelp at gmail.com> wrote:
>
>
>
> Hi Serge,
>
>  i don't know what's exactly going wrong with this. but one problem is that
> you don't have the redist installed. the latest version of VS 2005 force per
> default the manifest file building and the CRT lib. there should be 2
> solutions to solve this, i am not sure and i did test it, but i rember that
> i did once similar:
>
>  try to:
>  (1) remove manifest build
>  (2) try to et crt lib settings in the project
>
>  if you test it on a system VS 2005 installed, everythings works nice.
> otherwise i doesnt. so try to test also under xp (without installed VS 2005)
>
>
>  My current solution (including Microsoft.VC80.CRT folders) works with a
> fresh WinXP install (without VS8 nor redist package installed). But it
> doesn't work on a fresh Vista install, that is why I am so disappointed. :/
>
>  Anyone have manage to redistribute an OSG app on a Windows Vista without
> having to install the redistributable package ?
>
>  --
>  Serge Lages
>  http://www.magrathea-engine.org
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list