[osg-users] FBO

Robert Osfield robert.osfield at gmail.com
Tue Sep 25 01:10:06 PDT 2007


Hi Guy,

If you destroy a window then all the OpenGL objects associated with it
will be removed.  If you are using 2.0/osgViewer it should be able to
automatically release the OpenGL objects and reallocated them on the
new graphics context.

Which verison of the OSG/viewer library are you using?

Robert.

On 9/25/07, OSG at dvp.co.il <osg at dvp.co.il> wrote:
> Hi Robert,
>  in my application I have the scene graph in some variable, and a camera in
> another variable, then I attach it to viewer, in multi-document window.
> After I close the window, the scene graph & the camera are still alive.
> The next time I want to attach them to a new window I get OpenGL error that
> the frame buffer object is not complete (and nothing is drawn), so I wanted
> to force the renderstage to re-create it, and achieved this by setting the
> rendering cache of the existing camera to NULL.
>
> I just wanted to know if there is another and better way to deal with this
> problem, and also if you know why the FBO was defected after the window was
> closed.
>
> thanks,
>  Guy.
> ----- Original Message -----
> From: "Robert Osfield" <robert.osfield at gmail.com>
> To: "OpenSceneGraph Users" <osg-users at lists.openscenegraph.org>
> Sent: Monday, September 24, 2007 3:04 PM
> Subject: Re: [osg-users] FBO
>
>
> > Hi Guy,
> >
> > Have a look at the osgprerender example.  You shouldn't need to set
> > anything related to the render cache is this is managed internally.
> >
> > Robert.
> >
> > On 9/24/07, OSG at dvp.co.il <osg at dvp.co.il> wrote:
> > >
> > >
> > > OK, I got over it but I'm not sure that was the best way.
> > > What I did was to set the camera rendering cache (for the related
> contextID)
> > > to NULL, so the next time the cull visitor applied on the camera, it
> > > recreated the FBO. Any other ideas?
> > > thanks,
> > >  Guy.
> > >
> > > ----- Original Message -----
> > > From: OSG at dvp.co.il
> > > To: osg-users at lists.openscenegraph.org
> > > Sent: Monday, September 24, 2007 1:51 PM
> > > Subject: [osg-users] FBO
> > >
> > >
> > > Hi,
> > >  How do I enforce a camera to recreate FBO attached to the color buffer?
> > >
> > > thanks,
> > >  Guy.
> > >
> > >  ________________________________
> > >
> > >
> > > _______________________________________________
> > > osg-users mailing list
> > > osg-users at lists.openscenegraph.org
> > >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > >
> > >
> > > _______________________________________________
> > > osg-users mailing list
> > > osg-users at lists.openscenegraph.org
> > >
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> > >
> > >
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list