[osg-users] Error while building Virtual Planet Builder

om omkaranathan at darshan3d.com
Fri Sep 21 01:45:18 PDT 2007


hi Robert,
Could please tell where I can find VPB - 1.9.2 ??

The following is I could find from VPB webpage.

> The latest release 0.9.1, made 16th August 2007, can be download as 
> source code .zip archive : VirtualPlanetBuilder-0.9.1.zip 
> <http://www.openscenegraph.org/projects/VirtualPlanetBuilder/attachment/wiki/WikiStart/VirtualPlanetBuilder-0.9.1.zip> 
> or via SVN (subversion) access, to checkout the 0.9.1 release:
>
>svn checkout http://www.openscenegraph.org/svn/VirtualPlanetBuilder/tags/VirtualPlanetBuilder-0.9.1 VirtualPlanetBuilder
>  
>
Thanks.
Omkaranathan

Robert Osfield wrote:

>Hi Omkaranathan,
>
>You'll need to use the SVN version of OSG for the SVN version of
>VirtualPlanetBuilder (VPB).  VPB is undergoing a lot of structural
>changes right now so is not appropriate to use a base until I've got
>further through this work.  If you want a stable version you'll need
>to use the 1.9.2 release I made a few weeks back.
>
>Robert.
>
>On 9/21/07, om <omkaranathan at darshan3d.com> wrote:
>  
>
>>hi,
>>I am using Open Scene Graph version 2.1.11 and I have checked out latest
>>version of Virtual Planet Builder dated 20/09/07.
>>I am getting the following errors while build.
>>
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp: In member function
>>`bool TemplateSerializer<C, P>::read(osgDB::Input&, osg::Object& , bool&)':
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp:212:  error: 'class
>>osgDB::Input' has no member named 'read'
>>
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp: In member function
>>`bool Vec4Serializer<C>::read(osgDB::Input&, osg::Object&, bool& )':
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp:255:  error: 'class
>>osgDB::Input' has no member named 'read'
>>
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp: In member function `bool
>>GeospatialExtentsSerializer<C>::read(osgDB::Input&, osg::O bject&, bool&)':
>>/VirtualPlanetBuilder/src/vpb/DatabaseBuilder.cpp:343:  error: 'class
>>osgDB::Input' has no member named 'read'
>>
>>Can anybody please suggest which version of OSG to be used or how to
>>resolve this problem?
>>
>>Thanks
>>
>>Omkaranathan.
>>_______________________________________________
>>osg-users mailing list
>>osg-users at lists.openscenegraph.org
>>http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
>>    
>>
>_______________________________________________
>osg-users mailing list
>osg-users at lists.openscenegraph.org
>http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>
>  
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20070921/5aad887f/attachment-0003.htm>


More information about the osg-users mailing list