[osg-users] Error with current osgDotNet wrapper generators

Mike Wittman mwittman at seismicmicro.com
Thu Sep 20 15:45:02 PDT 2007


Hi Jason,

 

I don't see anything special about the osg::Texture::allocateMipmap
function interface that should cause that problem, and it sounds like
other pure virtual Texture functions are handled appropriately.
Possibly it could be due to a mismatch in OSG versions between headers
and wrapper DLLs.  I'll look into it when I have the chance.

 

-Mike

 

________________________________

From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Jason
Beverage
Sent: Thursday, September 20, 2007 10:22 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Error with current osgDotNet wrapper generators

 

Hi Mike,

I'll try to take a look at it this evening if I get a chance.  The only
issue I had with building the wrappers after I copied the dlls to the
bin folder was the fact that it didn't like the allocatemipmap was pure
virtual b/c osgDotNet was trying to create an instance of the Texture
class and it was abstract. 

Jason

On 9/20/07, Mike Wittman <mwittman at seismicmicro.com> wrote:

On 9/20/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> On 9/20/07, Jason Beverage <jasonbeverage at gmail.com> wrote: 
> > The error was because OSG is apparently installing the
osgwrapper_*.dll
> > files in the osgplugins directory instead of in the bin directory
like
> > normal.  Copying them to bin generates the wrappers.  Haven't tried 
> building
> > them yet though.
>
> I think this might be already fixed...

There's logic in the generator to handle the bin vs. plugins directory
change, and it's been working fine for me with 2.1.9.  It's gated in the
preprocessor based on OSG version, so it could be that you're picking up
old OSG headers when building the generator.  The logic in question is
in AugmentedTypesFactory::loadIntrospectionLibraries; I'd try dumping 
preprocessed source and/or stepping through in the debugger to see
what's happening.

-Mike
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20070920/25462822/attachment-0003.htm>


More information about the osg-users mailing list