[osg-users] Error with current osgDotNet wrapper generators

Mike Wittman mwittman at seismicmicro.com
Thu Sep 20 07:03:16 PDT 2007


On 9/20/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> On 9/20/07, Jason Beverage <jasonbeverage at gmail.com> wrote:
> > The error was because OSG is apparently installing the
osgwrapper_*.dll
> > files in the osgplugins directory instead of in the bin directory
like
> > normal.  Copying them to bin generates the wrappers.  Haven't tried
> building
> > them yet though.
> 
> I think this might be already fixed...

There's logic in the generator to handle the bin vs. plugins directory
change, and it's been working fine for me with 2.1.9.  It's gated in the
preprocessor based on OSG version, so it could be that you're picking up
old OSG headers when building the generator.  The logic in question is
in AugmentedTypesFactory::loadIntrospectionLibraries; I'd try dumping
preprocessed source and/or stepping through in the debugger to see
what's happening.

-Mike



More information about the osg-users mailing list