[osg-users] Background image texture rescaling problem

John Steinbis jsteinbis at gmail.com
Sat Sep 15 10:05:52 PDT 2007


I tryed disabling the resize of non power of two textures by using
"setResizeNonPowerOfTwoHint" but it did not seem to have any effect.
Do you think there is a bug or I just wasnt doing something right? You
can find the line where I tried this in my original post.

I havent been able to figure out how to set the position of a window.
How can I do this? Also, if I try to drag the window to a new
location, it freezes.

-- js


On 9/15/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> Hi John,
>
> On 9/15/07, John Steinbis <jsteinbis at gmail.com> wrote:
> > Thanks Robert,
> > I have this working now without rescaling the image. My solution was
> > to pad the image with zeros making it a power of two and then specify
> > the correct percentage of the image to use as 2D texture. Not sure if
> > this is the best solution but it works and is fast enough for me.
>
> This is not an elegant way to tackle the problem, workable yes, but
> I'd recommend spending a little time - readying up about
> TextureRectangle or just disabling the resize of non power of two
> textures, you'll end up with a more efficient and elegant solution.
>
> Robert.
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list