[osg-users] I still have 2 build issues (unices)

Robert Osfield robert.osfield at gmail.com
Fri Sep 14 02:14:52 PDT 2007


On 9/14/07, Mike Logan <mlogan at mail.arc.nasa.gov> wrote:
> Ok, so its seems to be just macs then.
> Linux dependencies seem fine.
>
>
> Maybe my problem is related to the previous thread
>  on Tessellator and Mac builds..

CMake must be picking up on the OpenGL framework rather the GLX
version of gl.h, or perhaps its the other way around, its assume the
OpenGL framework version bit getting the GLX gl.h version.

/Volumes/viz/OpenSceneGraph/src/osgUtil/Tessellator.cpp: In member
function 'void osgUtil::Tessellator::beginTessellation()':
/Volumes/viz/OpenSceneGraph/src/osgUtil/Tessellator.cpp:44: error:
invalid conversion from 'GLvoid (*)(...)' to 'GLvoid (*)()'

>From this I can't work out which way around it it your case.

In ccmake .. could you have a look at which verision of OpenGL it's using?

Robert.



More information about the osg-users mailing list