[osg-users] How to properly disable a plugin

Andy Skinner Andy.Skinner at mathworks.com
Thu Sep 13 05:17:23 PDT 2007


I don't have a specific change, because I am not familiar with this
aspect of things.  But I have wanted the same thing, with respect to
conflicts with some Apple-related plugins on 64 bit Macs.  So I'm for
it.  :)

andy

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Robert
Osfield
Sent: Thursday, September 13, 2007 5:13 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] How to properly disable a plugin

Hi Mike,

This experience suggest to me that we'd need to add an option for
disabling/enabling the compile of specific plugins.

Others are welcome to jump in and propose a set of changes.

Robert.

On 9/12/07, Mike Logan <mlogan at mail.arc.nasa.gov> wrote:
>
> Using latest svn today...
>
> I have an old Inventor install that keeps getting picked up by cmake.
> But I want to disable that plugin for now..    it won't compile.
>
> I changed to my build subdirectory and ran "ccmake .."  and was
>   able to change the values
>         INVENTOR_INCLUDE_DIR  =         INVENTOR_INCLUDE_DIR-NOTFOUND
>         INVENTOR_LIBRARY  =         INVENTOR_LIBRARY-NOTFOUND
>
> but I can't "generate" at that point within ccmake.
> I have to "configure" again and then generate
>   which ends up finding Inventor all over again.
>
> Editing CMakeCache.txt  directly also doesn't work, because  the
> subsequent 'make'
>   will cause a  "configure & generate" again.
>
> help.
>
> ml
>
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
>
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
>
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g



More information about the osg-users mailing list