[osg-users] Please test SVN version of OpenSceneGraph

Andy Skinner Andy.Skinner at mathworks.com
Wed Sep 12 08:18:59 PDT 2007


The Build.htm file for OpenThreads seems to say it worked.  I see the
linking, the "Creating library" output, and the Results section says 0
errors.

I haven't seen anything significant yet in the build output from
osgviewer and osgversion, but the former works and the latter doesn't.

I just saw the note from Blake, and that's the sort of thing I was
looking for.  Is OpenThreads listed in dependencies or similar for
osgviewer?

andy

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Robert
Osfield
Sent: Wednesday, September 12, 2007 11:00 AM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Please test SVN version of OpenSceneGraph

On 9/12/07, Andy Skinner <Andy.Skinner at mathworks.com> wrote:
> I just built a pretty recent (this morning) SVN on Windows with a -D
> OSG_MSVC_VERSIONED_DLL:BOOL=ON in the cmake command (we build from a
> makefile).

The OSG_MSVC_VERSIONED_DLL cmake var should now default to ON so you
shouldn't need to pass this into cmake anymore.

> It wasn't able to build osgversion, complaining about unresolved
> external symbol OpenThreadsGetSOVersion in function main.

This suggests either a problem with OpenThreads version or lack of
linking of OpenThreads - this was added to the osgversion
CMakeLists.txt file though so in theory it should work.

How are others under WIndows getting on?
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g



More information about the osg-users mailing list