[osg-users] textures and shader

mfritzen at uni-koblenz.de mfritzen at uni-koblenz.de
Mon Sep 3 08:26:34 PDT 2007


No I have not checked it. But I think the code is correct, because when I
use it without the vertex shader, it is working fine (the same code). The
warnings are just casting stuff, I will clean up now. But I think this is
not the problem, but I will also check my code with glvalidate.

>  Have you checked your shader with glvalidate program from 3dlabs?what
> are the warnings?these usually are important to resolve.
>
> On 9/3/07, mfritzen at uni-koblenz.de <mfritzen at uni-koblenz.de> wrote:
>> So, the notify thing is working now. I get the info logs when compiling,
>> but everything seems to be fine. The glProgram links correctly, just
>> some
>> casting warnings. I really don't know why it fails. Could there be a
>> problem with the gl_TextureMatrix[1] in the vertex program? What I want
>> is
>> simply to transfer the gl_TexCoords of my shadowMap to the frag program.
>> I
>> am still thankful for every hint.
>>
>> --marcus
>>
>> > Yeah, i have searched the website, but this I have not found ;) Thanks
>> > Robert.
>> >
>> >> http://www.openscenegraph.org/projects/osg/wiki/Support/TipsAndTricks
>> >>
>> >> On 9/3/07, mfritzen at uni-koblenz.de <mfritzen at uni-koblenz.de> wrote:
>> >>> Hi Mike,
>> >>>
>> >>> first thanks for your answer, but could you or someone else tell me
>> how
>> >>> to
>> >>> turn on the notify level? I never worked with it.
>> >>>
>> >>> Thanks.
>> >>>
>> >>> > Hi,
>> >>> >
>> >>> > Turn up the notify level to retrieve the infologs for compilation
>> and
>> >>> > linking.  There could be some other error preventing creation of a
>> >>> > functioning glProgram.
>> >>> >
>> >>> > -- mew
>> >>> >
>> >>> >
>> >>> > Mike Weiblen -- Zebra Imaging -- Austin Texas USA --
>> >>> > http://www.zebraimaging.com/
>> >>> >
>> >>> >> -----Original Message-----
>> >>> >> From: osg-users-bounces at lists.openscenegraph.org
>> [mailto:osg-users-
>> >>> >> bounces at lists.openscenegraph.org] On Behalf Of Marcus Fritzen
>> >>> >> Sent: Thursday, August 30, 2007 4:24 AM
>> >>> >> To: osg-users at lists.openscenegraph.org
>> >>> >> Subject: [osg-users] textures and shader
>> >>> >>
>> >>> >> Hello,
>> >>> >>
>> >>> >> I have a little problem using texture coordinates with shader.
>> The
>> >>> >> problem is, if I use a vertex program with varying for the
>> fragment
>> >>> >> program, the texture coordinates seem to be incorrect, but if I
>> just
>> >>> > use
>> >>> >> the fragment program without the vertex program everything is
>> fine.
>> >>> > For
>> >>> >> example when computing shadows:
>> >>> >>
>> >>> >> VERT
>> >>> >> ...
>> >>> >> vertex = gl_ModelViewMatrix * gl_Vertex;
>> >>> >> gl_TexCoord[0] = gl_MultiTexCoord0;
>> >>> >> gl_TexCoord[1] = gl_TextureMatrix[1] * vertex;
>> >>> >> ...
>> >>> >> FRAG
>> >>> >> ...
>> >>> >> float depth = shadow2DProj( shadowTexture, gl_TexCoord[1] ).x;
>> >>> >> ...
>> >>> >> this is not working. On texture unit 0 is the base texture, on 1
>> the
>> >>> >> shadowmap. But without the vertex program it is working. Anybody
>> any
>> >>> >> hints?
>> >>> >>
>> >>> >> Thanks,
>> >>> >> Marcus
>> >>> >> _______________________________________________
>> >>> >> osg-users mailing list
>> >>> >> osg-users at lists.openscenegraph.org
>> >>> >>
>> >>> >
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
>> >>> > g
>> >>> > _______________________________________________
>> >>> > osg-users mailing list
>> >>> > osg-users at lists.openscenegraph.org
>> >>> >
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >>> >
>> >>>
>> >>>
>> >>> _______________________________________________
>> >>> osg-users mailing list
>> >>> osg-users at lists.openscenegraph.org
>> >>>
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >>>
>> >> _______________________________________________
>> >> osg-users mailing list
>> >> osg-users at lists.openscenegraph.org
>> >> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >>
>> >
>> >
>> > _______________________________________________
>> > osg-users mailing list
>> > osg-users at lists.openscenegraph.org
>> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>> >
>>
>>
>> _______________________________________________
>> osg-users mailing list
>> osg-users at lists.openscenegraph.org
>> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>





More information about the osg-users mailing list