[osg-users] MFC example flickering

Felix Bwire bwifex at gmail.com
Mon Sep 3 05:18:26 PDT 2007


Hi all,

I have managed to build openscenegraph in eclipse using cmake. I have
created a class in the same project used for building and when I try
to run, I get the error: "Error launching. Reason:
JavalangNullPointerException".

Does anyone know the steps to follow to create an application after
being able to build osg in eclipse.

I will be grateful

Thanx,
Felix

On 9/3/07, Robert Osfield <robert.osfield at gmail.com> wrote:
> Thanks Amalric, changes now merged and submitted to SVN.
>
> One thing to note is that you sent MFC_OSG_MDIDoc.h instead of
> MFC_OSG_MDIView.h, so I had to guess at the required changes the
> later, it looked quite straight forward but since I don't have a
> windows build system I can't test it.
>
> Could you(and other Windows users) do a svn update and test what I
> have just checked in to make sure the it works fine.
>
> Cheers,
> Robert.
>
> On 8/31/07, amalric alexandre <alex.pixxim at gmail.com> wrote:
> > Hi osg-users,
> >
> > I've noticed that all osgViewerMFC example from osg 2.x.x are flickering
> > when resizing 3D view, to avoid this only add OnEraseBkgnd callback in
> > CMFC_OSG_MDIView class and do nothing in it. Just like the WxWidget
> example.
> >
> > Attached the modified version of MFC_OSG_MDIView.cpp and
> MFC_OSG_MDIView.h.
> >
> > Hope it will help.
> > _______________________________________________
> > osg-users mailing list
> > osg-users at lists.openscenegraph.org
> > http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
> >
> >
> >
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>



More information about the osg-users mailing list