[osg-users] Redistribute OSG on Vista

Serge Lages serge.lages at gmail.com
Thu Sep 27 01:58:53 PDT 2007


Hi all,

Here is my problem : I develop with WinXP and VS8 SP1, and I have an OSG
application I need to redistribute on Win2K, WinXP and Vista. The important
thing to note is that the users will not have administration rights on their
computers when installing my application. That's why I can't install
Microsoft's vcredist_x86.exe on these computers.

So to make it work, I followed the instructions here (the second method) :
http://msdn2.microsoft.com/library/ms235291(VS.80).aspx
I have put Microsoft.VC80.CRT folders with the correct dlls and manifest
everywhere I have a dll (into the main binary folder and into the
osgPlugins-* folder).
Under WinXP and Win2K it works great but not on Vista. It makes my
application crash. Its weird because if I don't put a
Microsoft.VC80.CRTfolder into the plugins folder, my application
doesn't crash (but no
textures or objects are loaded as the plugins fail to be loaded). So it
seems to come from the plugins.

Anyone as a clue on what I am doing wrong ?
Thanks in advance for any help.

PS : Of course, if I install vcredist_x86.exe on the Vista computer, my
application works normally, so it's really a redistribution issue.

-- 
Serge Lages
http://www.magrathea-engine.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20070927/45d74807/attachment-0002.htm>


More information about the osg-users mailing list