[osg-users] OSG Preset Uniforms GLSL

Kim C Bale K.Bale at hull.ac.uk
Fri Oct 26 02:14:32 PDT 2007


Thanks for your prompt reply on this, I hadn't realized that I have to
declare the uniform. Works a treat now. 

Regards,

Kim.

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of Mike
Weiblen
Sent: 26 October 2007 08:07
To: OpenSceneGraph Users
Subject: Re: [osg-users] OSG Preset Uniforms GLSL

Hi,

I just tested osg_ViewMatrix on OSG 2.2 win32 binaries using
glsl_dataflag.osg and drawtext4.frag from osgToy, and yes it does
continue
to work.

While osg_ViewMatrix is preset by OSG, you do still have to declare it
in
your shader (eg uniform mat4 osg_ViewMatrix), unlike the gl_* presets.

Turn up the OSG notify level, are you getting any infologs during
compile/link?

-- mew



On Thu, October 25, 2007 10:56, Kim C Bale wrote:
> Hi all,
>
> Is osg_ViewMatrix still supported as a preset uniform? I can't seem to
> get it to recognise it within my glsl shader. Is it purely a driver
> issue with my nv7800GS or do I need to do something special to enable
me
> to use it?
>
> Thanks,
>
> Kim.
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20071026/53737008/attachment-0002.asc>


More information about the osg-users mailing list