[osg-users] Collada Plugin DAE build errors

Wojciech Lewandowski lewandowski at ai.com.pl
Tue Oct 23 23:52:45 PDT 2007


Hi, I don't know how to make static link. But I succeeded in using dynamic
Colllada DLLs.

To make it work:
1 define DYNAMIC_DOM macro for the plugin (this forces using dllimports on
collada symbols in the plugin)
2 from all collada related libs use only libcollada141dom13.lib (import
library) remove other libs from the link line
(delete inputs of libcollada_dom.lib libcollada_dae.lib
libcollada_STLDatabase.lib libcollada_LIBXMLPlugin.lib
libcollada_stdErrPlugin.lib libxml2.lib)
3 compile and build and install (it works for me)
4 unfortunately latest cmake build keeps restoring project settings when
install is build. You may need to redo steps 1-2 before each build. I help
myself here by building and installing Collada plugin once then unload
project from solution. Otherwise each consecutive build and install stops on
errors due to restored faulty settings.

I may be wrong here, but I saw few weeks ago that Collada maintainer
submitted some fix to make it build as dynamic by default. But I guess this
submit did not get into distribution yet.

Regards,
Wojtek Lewandowski




-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org]On Behalf Of Hamm,
Brandon
Sent: Tuesday, October 23, 2007 11:20 PM
To: OpenSceneGraph Users
Subject: Re: [osg-users] Collada Plugin DAE build errors


I have this same issue - such that I've yet to have it build
successfully on Windows.  I HAVE got it successfully built and used it
in a Linux environment, though.  If you do get it built on Windows,
please post your solution as I would certainly appreciate it.

Thanks,

Brandon Hamm
SimAuthor, Inc.

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of
kbeal at kc.rr.com
Sent: Sunday, October 21, 2007 7:49 PM
To: osg-users at lists.openscenegraph.org
Subject: [osg-users] Collada Plugin DAE build errors

I have this same problem.  I tried removing LIBXML_STATIC from the
preprocessor defines in LIBXMLPlugin.vcproj and rebuilt and still get
the same error.

Adrian Egli wrote:
> hi
>
> (1) i downloaded the collada prebuild library from
> http://sourceforge.net/projects/collada-dom
> (2) installed the prebuild library
> http://sourceforge.net/project/showfiles.php?group_id=157838&package_i
> d=211510
> <http://sourceforge.net/project/showfiles.php?group_id=157838&package_
> id=211510>
> (17.04.2007)
> (3) c-make configurated
> (4) build osg with VC 7 and got the following errors:
>
> Plug 3d dae error LNK2019: unresolved external symbol _xmlFree
> referenced in function "private: void __thiscall
> daeLIBXMLPlugin::readAttributes(class daeElement *,struct
> _xmlTextReader *)"
> (?readAttributes <at>
> daeLIBXMLPlugin@@AAEXPAVdaeElement@@PAU_xmlTextReader@@@Z)
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org





More information about the osg-users mailing list