[osg-users] Collada Plugin DAE build errors

Hamm, Brandon hamm at simauthor.com
Tue Oct 23 14:19:49 PDT 2007


I have this same issue - such that I've yet to have it build
successfully on Windows.  I HAVE got it successfully built and used it
in a Linux environment, though.  If you do get it built on Windows,
please post your solution as I would certainly appreciate it.

Thanks,

Brandon Hamm
SimAuthor, Inc. 

-----Original Message-----
From: osg-users-bounces at lists.openscenegraph.org
[mailto:osg-users-bounces at lists.openscenegraph.org] On Behalf Of
kbeal at kc.rr.com
Sent: Sunday, October 21, 2007 7:49 PM
To: osg-users at lists.openscenegraph.org
Subject: [osg-users] Collada Plugin DAE build errors

I have this same problem.  I tried removing LIBXML_STATIC from the
preprocessor defines in LIBXMLPlugin.vcproj and rebuilt and still get
the same error.

Adrian Egli wrote:
> hi
>
> (1) i downloaded the collada prebuild library from 
> http://sourceforge.net/projects/collada-dom
> (2) installed the prebuild library
> http://sourceforge.net/project/showfiles.php?group_id=157838&package_i
> d=211510 
> <http://sourceforge.net/project/showfiles.php?group_id=157838&package_
> id=211510>
> (17.04.2007)
> (3) c-make configurated
> (4) build osg with VC 7 and got the following errors:
>
> Plug 3d dae error LNK2019: unresolved external symbol _xmlFree 
> referenced in function "private: void __thiscall 
> daeLIBXMLPlugin::readAttributes(class daeElement *,struct 
> _xmlTextReader *)"
> (?readAttributes <at> 
> daeLIBXMLPlugin@@AAEXPAVdaeElement@@PAU_xmlTextReader@@@Z)
_______________________________________________
osg-users mailing list
osg-users at lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.or
g



More information about the osg-users mailing list