[osg-users] Frustum specialists look here.

Johan Johnsson eslave at gmail.com
Mon Oct 22 05:33:54 PDT 2007


If this can help : i get the same problem if i dont set the  
camera->setShareLens(false);
on my old project,..

can i set a flag in OSG v2.0 that corresponds to  
camera->setShareLens(false) in OSG v1.0? :D




On Mon, 22 Oct 2007 11:14:44 +0200, Robert Osfield  
<robert.osfield at gmail.com> wrote:

> On 10/22/07, Johan Johnsson <eslave at gmail.com> wrote:
>> unfortually, have i no time to laborate with the osg examples atm.
>> I have found out that its ONLY on the slaves the frustum gets wierd.
>> the master camera always shows the correct frustum.
>>
>> camera->setProjectionResizePolicy(osg::Camera::FIXED);
>>
>> above has nothing to do with it.
>
> I'm afraid there isn't much I can do at my end to help without being
> able to see the problem first hand there is just too many unknowns
> about what you might be doing at your end.
>
> osgViewer/osg::Camera's support for master and slaves should provide
> you with all the functionality you need and the fact you aren't
> getting the right result is most likely down to a misunderstanding of
> how the master and slave cameras are set up.  It could be a bug of
> course, but without have code to review there is nothing I can do.
>
> Robert.
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org



-- 
Mr. Johan Johnsson
AutoSim AS, Strandveien 106, 9006 Tromsø
Visit us at http://www.autosim.no



More information about the osg-users mailing list