[osg-users] OpenFlt file causing crash in optimizer

Robert Osfield robert.osfield at gmail.com
Wed Oct 17 06:52:49 PDT 2007


Hi Mark,

A six poly file would be ideal to test against, just post it as an
attachment to an osg-users email if the file is small.

Just to be precise, does:

  osgviewer myfile.flt

Fail?

Robert.

On 10/17/07, Mark Hurry <mark at dwork.com> wrote:
>
>
>
>
> Hi Robert,
>
>
>
> Not sure what you mean by directly. I have set it up as command line
> argument in VS2005. I have also tried osgviewerMFC with the same results.
>
>
>
> I have reduced the OpenFlight model down to about 6 polys that still
> produces the same crash, so what's the best way of making it available to
> everyone?
>
>
>
> I'll carry on investiagting more to see if I can narrow the problem down as
> this is a show stopper for me
>
>
>
> Cheers
>
>
>
> Mark
>
>   >Hi Mark,
> >
> >I don't know of any hacks you could apply to fix this, in the end one
> >will have to track down the bug be it in osgUtil::Optimizer or the
> >OpenFlight plugin.
>
> >Does osgviewer crash if you load the OpenFlight file directly?  Would
> >it be possible to make a model that reproduces the crash available so
> >the community can assist in tracking down the bug?
>
> >Robert.
> >
> >On 10/17/07, Mark Hurry <mark at dwork.com> wrote:
> >>
> >> I have been trying to load an OpenFlight file created using TerraVista
> using
> >> osgViewer. However I have been getting a crash in the optimizer code in
> >> Optimizer::MergeGeodesVisitor::mergeGeodes at line
> >> geodeDuplicateMap[geode].push_back(geode); I finally
> >> managed to track down that in the OpenFlight format polygon attributes
> there
> >> is a flag for "Hidden polygon". If this flag is set it causes a crash, if
> it
> >> is not set then the model loads.
> >>
> >>
> >>
> >> Is this a known problem? And if so is there a work around? Obviously it
> is
> >> not feasable to go into each OpenFlight file and manually check each
> polygon
> >> to see if the "Hidden polygon" flag has been set.
> >>
> >>
> >>
> >> Thanks in advance
> >>
> >>
> >>
> >> Mark
> >>
>
>
> >>
>
>
> No virus found in this outgoing message.
>  Checked by AVG Free Edition.
>  Version: 7.5.488 / Virus Database: 269.14.13/1074 - Release Date: 16-Oct-07
> 2:14 PM
>
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org
>
>



More information about the osg-users mailing list